I'm having performance issues with HAP AC (IPTV stuttering when downloading / high CPU load).
setup info:
FTTH 200/100
ONT <-> ether1 (with 2 VLANs, one for pppoe and another for IPTV)
Bridge1: ether3 - ether5 & wifi
bridge2: iptv vlan & ether2
There are just basic firewall rules (default setup with fasttrack and masquerade)
when I use ISPs router (set up in bridge mode) there is no stuttering
When downloading CPU usage jumps to 50 - 70%, depending if test is being performed via WiFi or cable
Config:
Code: Select all
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/interface bridge
add admin-mac=AA:AA:AA:AA:AA:AA auto-mac=no comment=defconf name=IPTV
add admin-mac=AA:AA:AA:AA:AA:AA auto-mac=no comment=defconf name=Local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=wifi wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-onlyac channel-width=20/40/80mhz-Ceee disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=wifi-AC wireless-protocol=802.11
/interface vlan
add interface=ether1 name=ether1.100 vlan-id=100
add interface=ether1 name=ether1.101 vlan-id=101
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1.100 name=pppoe-out1 password=password user=user
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=password wpa2-pre-shared-key=password
/interface bridge port
add bridge=IPTV comment=defconf interface=ether1.101
add bridge=Local comment=defconf interface=ether3
add bridge=Local comment=defconf interface=ether4
add bridge=Local comment=defconf interface=ether5
add bridge=Local comment=defconf interface=sfp1
add bridge=Local comment=defconf interface=wlan1
add bridge=Local comment=defconf interface=wlan2
add bridge=IPTV comment=defconf interface=ether2
/interface list member
add comment=defconf interface=Local list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN