I literally just setup an l2tp vpn server today.
There's a lot of different tutorials and conflicting info out there, but for the simplest config, the wiki is best:
https://wiki.mikrotik.com/wiki/Manual:I ... pSec_setup
This worked for me:
[add ip pool for vpn clients]
/ip pool add name=vpn-pool range=192.168.1.40-192.168.1.49 (I just took out a handful of IPs from the dhcp server ip pool of the main subnet)
[create vpn profile]
/ppp profile
add local-address=vpn-pool name=l2tp-vpn remote-address=vpn-pool (you can also set it up like in the wiki)
[create vpn login]
/ppp secret
add name=vpn password=password profile=l2tp-vpn
[enable l2tp server]
/interface l2tp-server server
set enabled=yes use-ipsec=required ipsec-secret=mySecret default-profile=l2tp-vpn (it's configured from the "L2tp server" tab, NOT the "+")
[be sure to add these firewall rules if using the default config]
/ip firewall filter
add chain=input protocol=udp port=1701,500,4500
add chain=input protocol=ipsec-esp
once it's setup, you can connect to the vpn in ios or in windows.