You mean I need to manage dhcpv6 server + IPv6 advertising?Microsoft only added support for DNS from RA not so long ago. And as far as I know, only to Windows 10, no backports. But you can use DHCPv6, RouterOS supports stateless server.
That's what I meant. Will try, thanks!You already have advertising, so you just need to enable other config in options, add DHCPv6 server to same interface without specifying pool and it will work in stateless mode and provide info to clients that ask (as instructed by other config flag in RA).
Can anyone confirm this?Stateless DHCPv6 now working. Works only ND and RA and static DNSv6.
/ipv6 address
add address=2001:db8::1/64 interface=ether3
/ipv6 nd
set [ find default=yes ] other-configuration=yes
/ipv6 dhcp-server option
add code=23 name=dnsrecursivenameserver value=0x20010db800000000000000000000000220010db8000000000000000000000003
add code=24 name=domainsearchlist value=0x076578616d706c65036e657400076578616d706c6503636f6d00
/ipv6 dhcp-server
add dhcp-option=dnsrecursivenameserver,domainsearchlist interface=ether3 name=server1
Ethernet adapter Ethernet:
Connection-specific DNS Suffix . : example.net
Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection
Physical Address. . . . . . . . . : 00-0C-29-46-67-17
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:db8::adcd:16f7:b9b5:6516(Preferred)
Temporary IPv6 Address. . . . . . : 2001:db8::14a5:337e:7a50:8ea0(Preferred)
Link-local IPv6 Address . . . . . : fe80::adcd:16f7:b9b5:6516%3(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.101.22(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : fe80::20c:29ff:feef:fd4%3
DHCPv6 IAID . . . . . . . . . . . : 50334761
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-0A-34-DF-00-0C-29-46-67-17
DNS Servers . . . . . . . . . . . : 2001:db8::2
2001:db8::3
NetBIOS over Tcpip. . . . . . . . : Enabled
Connection-specific DNS Suffix Search List :
example.net
example.com
/ip dns
set allow-remote-requests=yes servers=192.168.80.1,192.168.80.3,2001:db8::4,2001:db8::5
/ipv6 address
add address=2001:db8::1/64 interface=ether3
/ipv6 nd
set [ find default=yes ] other-configuration=yes
/ipv6 dhcp-server
add interface=ether3 name=server1
Ethernet adapter Ethernet:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection
Physical Address. . . . . . . . . : 00-0C-29-46-67-17
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:db8::adcd:16f7:b9b5:6516(Preferred)
Temporary IPv6 Address. . . . . . : 2001:db8::a465:670:f11a:95be(Preferred)
Link-local IPv6 Address . . . . . : fe80::adcd:16f7:b9b5:6516%3(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.101.22(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : fe80::20c:29ff:feef:fd4%3
DHCPv6 IAID . . . . . . . . . . . : 50334761
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-0A-34-DF-00-0C-29-46-67-17
DNS Servers . . . . . . . . . . . : 2001:db8::4
2001:db8::5
NetBIOS over Tcpip. . . . . . . . : Enabled
ConfirmedWell what happens is that :
If I say I use SLAAC (managed=0)
My Windows hosts uses SLAAC just all right, but has no DNS
If I say I use SLAAC (managed=0) and want to provide DNS throught DHCPV6 (other=1)
My Windows hosts uses SLAAC just all right, but still has no DNS : it performs no DHCPV6 request at all to my router
If I say I use managed DHCPV6 config (managed=1)
My Windows hosts still uses SLAAC not performing DHCPV6 requests. Mikrotik still sends the A flag in Prefix Information, which means SLAAC should be used. My host then receives two opposite meaning messages, and the stack then assumes SLAAC, and does not perform DHCP requests.
If I force a DHCP renew on my host
Whatever network IPV6 config, if I force my Windows host to an address renew , it then performs a DHCP request to my Mikrotik, but that one does not answer, and logs "handling only prefix delegation discarding"
Please, have a look at that presentation which gives some details : http://www.swissipv6council.ch/sites/de ... 150430.pdf
It works here, it's the simple example I posted.If I say I use SLAAC (managed=0) and want to provide DNS throught DHCPV6 (other=1)
My Windows hosts uses SLAAC just all right, but still has no DNS : it performs no DHCPV6 request at all to my router
If you don't like A flag and you didn't configure prefix manually in "/ipv6 nd prefix", you can disable it in "/ipv6 nd prefix default".If I say I use managed DHCPV6 config (managed=1)
My Windows hosts still uses SLAAC not performing DHCPV6 requests. Mikrotik still sends the A flag in Prefix Information, which means SLAAC should be used. My host then receives two opposite meaning messages, and the stack then assumes SLAAC, and does not perform DHCP requests.