Firewall Sequence - Rules not executed orderly
Posted: Sun May 27, 2018 5:00 pm
My dilemma, is that I have RB3011 and on ether5 I want to put a network with is to be used for specific few IPs:
However, when testing, everything gets dropped. When I disable "Drop anything attempting to pass through Demo_Farm LAN that doesn't match the rules above" traffic passes, so the address-list IPs are not being processed which are before the drop rule, does anyone know why something like that would happen?
Code: Select all
/ip firewall filter
add action=accept chain=forward comment="FORWARD Chain - Packets towards Mikrotik itself (Established,Related)" connection-state=established,related
add action=accept chain=forward comment="Permit DNS requests from clients over TCP" dst-port=53 in-interface=ether5 protocol=tcp
add action=accept chain=forward comment="Approved Demo_Farm" dst-address-list=Demo_Farm dst-port=15000-15100,50000-50200 in-interface=ether5 out-interface=Ovpn protocol=tcp src-address-list=permitted-local-sources
add action=accept chain=forward comment="Approved HTTP" dst-address-list=permitted-http-destinations-address dst-port=80 in-interface=ether5 out-interface=Ovpn protocol=tcp src-address-list=permitted-local-sources
add action=accept chain=forward comment="Approved HTTPS" dst-address-list=permitted-https-destinations-address dst-port=443 in-interface=ether5 out-interface=Ovpn protocol=tcp src-address-list=permitted-local-sources
add action=drop chain=forward comment="Drop anything attempting to pass through Demo_Farm LAN that doesn't match the rules above" in-interface=ether5 out-interface=Ovpn
/ip firewall address-list
add address=72.XXX.XXX.152 comment="Demo#1" list=permitted-http-destinations-address
add address=79.XXX.XXX.28 comment=Demo2 list=permitted-https-destinations-address
add address=192.XXX.XXX.15 comment="Local Permitted IP Address" list=permitted-local-sources
add address=XXX.XXX.156.1-XXX.XXX.156.255 list=Demo_Farm
add address=XXX.XXX.148.1-XXX.XXX.148.255 list=Demo_Farm