Hi
How Can Using a Mikrotik router to PXE Boot?
Thank you
I did it- setup DHCP server with the required options for your client
- add storage to your router for the required bootfiles (USB stick, SD card, M.2 card, whatever fits your router)
- put required bootfiles on the storage
- configure TFTP service with these files
Still not working in ROS 7.10. The error is still the same "permission denied!", in the log it appears as:Hello,
Really interested in a solution. Trying to setup a PXE boot server. For initial testing I've setup a standalone network on a CCR1009. OS 6.40.8.
4 ports in a bridge to a DHCP server for a single LAN 192.168.0.0/24. DHCP lease scope 192.168.0.10-50. Options set for PXE boot, but this doesn't really matter yet since I'm first just trying to get the tftp to work.... There's no firewall or routing.
Used the CCR to format an SD card fat32. Used the FTP protocol to copy the files from another working PXE server. The files are located in disk1/tftpboot . (again need to focus on tftp first)
I've used several dozen versions of the syntax to setup the tftp server. (Also MS Windows native tftp client, and a third party download).
/ip tftp add allow-rollover=yes real-filename=disk1/tftpboot/ req-filename=.*
Just to try and get some success I tried
/ip tftp add allow-rollover=yes real-filename=disk1/tftpboot/pxelinux.0 req-filename=pxelinux.0
Sometimes I specify the 192.168.0.0/24 for allowed. Sometimes I specify 0.0.0.0 Most of the time I leave this blank.
There are three result...
ERROR code;0 string:permission denied!
or
ERROR code:1 string: file no found (typically when I deliberately GET something invalid like a file I know isn't there)
ERROR code: 8 (no other text after this. (This occurs when I boot a NUC on this LAN, which indicates DHCP is working.).
When I specify a req-filename (specific or wildcard) the tftp GET fails immediately (usually with permission denied)
If I don't specify any req-filename the GET command has to time out or exhaust all retries.
Ultimately I would like a blank (or wildcard) req-filename parameter, and a real-filename parameter that sets disk1/tftpboot folder as the TFTP root....
This shouldn't be hard.
Anyone out there have any success with this.
Thanks
Kevin
I tried removing the IP address parameter as this is like an ACL, but now the error is: Error 8 (no more info)Still not working in ROS 7.10. The error is still the same "permission denied!", in the log it appears as:Hello,
Really interested in a solution. Trying to setup a PXE boot server. For initial testing I've setup a standalone network on a CCR1009. OS 6.40.8.
4 ports in a bridge to a DHCP server for a single LAN 192.168.0.0/24. DHCP lease scope 192.168.0.10-50. Options set for PXE boot, but this doesn't really matter yet since I'm first just trying to get the tftp to work.... There's no firewall or routing.
Used the CCR to format an SD card fat32. Used the FTP protocol to copy the files from another working PXE server. The files are located in disk1/tftpboot . (again need to focus on tftp first)
I've used several dozen versions of the syntax to setup the tftp server. (Also MS Windows native tftp client, and a third party download).
/ip tftp add allow-rollover=yes real-filename=disk1/tftpboot/ req-filename=.*
Just to try and get some success I tried
/ip tftp add allow-rollover=yes real-filename=disk1/tftpboot/pxelinux.0 req-filename=pxelinux.0
Sometimes I specify the 192.168.0.0/24 for allowed. Sometimes I specify 0.0.0.0 Most of the time I leave this blank.
There are three result...
ERROR code;0 string:permission denied!
or
ERROR code:1 string: file no found (typically when I deliberately GET something invalid like a file I know isn't there)
ERROR code: 8 (no other text after this. (This occurs when I boot a NUC on this LAN, which indicates DHCP is working.).
When I specify a req-filename (specific or wildcard) the tftp GET fails immediately (usually with permission denied)
If I don't specify any req-filename the GET command has to time out or exhaust all retries.
Ultimately I would like a blank (or wildcard) req-filename parameter, and a real-filename parameter that sets disk1/tftpboot folder as the TFTP root....
This shouldn't be hard.
Anyone out there have any success with this.
Thanks
Kevin
ERROR code:0 string:permission denied!
If i increase the logging to DEBUG, an additional line appears before:
requested file(binary): pxeboot access: denied
this is strange as there is no permission setting in the router.
I i use a different external tftp server there is no problem to get the boot file, but this SHOULD work on ROS.
/ip dhcp-server option
add code=66 name=boot-server value="IP_of_PXE_Server"
add code=67 name=boot-file value="pxelinux.0"
"... Unknown data type"
/ip dhcp-server option
add code=66 name=pxe-boot-server value="'10.13.37.113'"
add code=67 name=boot-file value="'netboot.xyz.kpxe'"
/ip dhcp-server option sets
add name=NetworkBoot options=pxe-boot-server,boot-file
/ip dhcp-server network
add address=10.13.37.0/24 dhcp-option-set=NetworkBoot dns-server=10.0.2.11,10.0.2.12,1.1.1.1 gateway=10.13.37.1 \
next-server=10.13.37.113