Trouble connecting u-boot to a RB922
Posted: Wed Oct 17, 2018 11:58 am
Hi!
(EDIT: For a work-around, see my answer below. Nevertheless, I still want to understand what's going on here, so if you have any clue, please let me know!)
I've got some trouble with u-boot running on an ARM board connecting to a RB922UAGS-5HPacD, and I'm not sure where I should start digging. Everything works fine if I connect to a CRS125-24G-1S or if there is another switch between the RB922 and my ARM board, but with a straight cable between the two, they refuse to talk to each other. This is my setup:
If I put a switch between the Orange Pi and the RB922, everything works fine. I've tried this with a cheap unmanaged Gbit-switch as well as with my CRS125.
If I connect the Orange Pi directly to the CRS125 and configure tftp on the CRS125, everything works fine, too. Note that the configuration of the CRS125 is not exactly the same as the RB922:
Once the Linux kernel is up and running, the straight connection between Orange Pi and RB922 works fine. It's just u-boot, and only with a direct connection to the RB922.
Any clues what I should have a closer look at? Do you need more information?
Thanks a lot,
Hendrik
(EDIT: For a work-around, see my answer below. Nevertheless, I still want to understand what's going on here, so if you have any clue, please let me know!)
I've got some trouble with u-boot running on an ARM board connecting to a RB922UAGS-5HPacD, and I'm not sure where I should start digging. Everything works fine if I connect to a CRS125-24G-1S or if there is another switch between the RB922 and my ARM board, but with a straight cable between the two, they refuse to talk to each other. This is my setup:
- Orange Pi PC Plus (Allwinner H3) with u-boot 2017.11-armbian shall load the Linux kernel using tftp.
Relevant configuration / commands:
Code: Select allsetenv ipaddr 192.168.3.74 setenv serverip 192.168.3.73 tftpboot 0x44000000 some_file.scr
- RB922UAGS-5HPacD relevant configuration:
Code: Select all/ip address add address=192.168.3.73/24 interface=ether1 /interface ethernet set [ find default-name=ether1 ] disabled=no /ip tftp add ip-addresses=192.168.3.0/24 allow-rollover=yes req-filename=some_file.scr real-filename=some_file.scr read-only=yes
If I put a switch between the Orange Pi and the RB922, everything works fine. I've tried this with a cheap unmanaged Gbit-switch as well as with my CRS125.
If I connect the Orange Pi directly to the CRS125 and configure tftp on the CRS125, everything works fine, too. Note that the configuration of the CRS125 is not exactly the same as the RB922:
Code: Select all
/interface bridge add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no fast-forward=no name=bridge-lan
/interface bridge port add bridge=bridge-lan interface=ether2
/interface bridge port add bridge=bridge-lan interface=ether3
/interface bridge port add bridge=bridge-lan interface=ether4 etc.
/ip address add address=192.168.3.1/24 interface=bridge-lan network=192.168.3.0
/ip tftp add ip-addresses=192.168.3.0/24 allow-rollover=yes req-filename=some_file.scr real-filename=some_file.scr read-only=yes
# (yes, I changed "serverip" in u-boot for this test)
Any clues what I should have a closer look at? Do you need more information?
Thanks a lot,
Hendrik