Hmmm,
Looking through your list
/interface list member
add interface=ether1 list=WAN
add interface=bridge1 list=LAN
99?????
add list=LAN
a. where is bridge99 on the - LAN list
/interface list member
b. I think the add list=LAN entry is in error and should be removed
/ip address
add address=192.168.2.1/24
interface=ether2 network=192.168.2.0
/interface bridge port
add bridge=
bridge1 interface=ether2
c. Compare this address rule to the listing in bridge ports, the interface should be bridge1
/ip firewall filter
add action=drop chain=forward disabled=yes
add action=accept chain=forward
d. First two firewall rules are strange, removing them both for now, but considering taking the first one and making it your LAST RULE in the forward chain,
In other words clearly state what you need to allow, and then at the end drop everything else (don't forget to enable the rule).
In addition for reading sake, put the forward chain rules AFTER the input chain rules.
{edit: I note another poster has also commented on the second rule above, quite correct it needs to be punted to a land far far away}
e. Your rules to block 99 to the LAN and LAN to 99 should work because they are on separate bridges.
f. Your rule to block .200 and below from .201 and above on the same IP pool on the same bridge will NOT WORK.
They are both on the same bridge and thus connected at layer 2.
/ip firewall nat
add
action=accept chain=srcnat dst-address=192.168.0.0/24 src-address=\
192.168.2.0/24
g. Call me cwazee but a NAT rule should have an action that is scr-nat or dst-nat or masquerade, NOT accept?????? I will note that I am not familiar with all the uses of NAT so you may be doing something perfectly legitimate here.
h. Only the first dstnat rule has the IN-INTERFACE, the rest are missing this necessary component. (also the first 3 rules are disabled)
/ip firewall raw
add action=notrack chain=prerouting dst-address=192.168.0.0/24 src-address=\
192.168.2.0/24
i. Dont have a sweet clue as to what this raw rule does???