On port 1 it is set up with DHCP client and it gets address.
Ports 2 - 5 are in bridge and bridge has IP 10.10.252.251.
Router acts as DHCP server and gives right addresses and it is also configured as CapsMan which is working as it should.
Here is configuration:
Code: Select all
# nov/23/2018 20:20:06 by RouterOS 6.39.1
# software id = LXKL-XSPZ
#
/interface bridge
add name=CapsMan_Bridge
/interface ethernet
set [ find default-name=ether5 ] poe-out=forced-on
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/caps-man datapath
add bridge=CapsMan_Bridge name=BCDAdria_datapath
/caps-man security
add authentication-types=wpa-psk,wpa2-psk encryption="" name=BCDAdria_pass \
passphrase=24681357
/caps-man configuration
add country=croatia datapath=BCDAdria_datapath name=BCDAdria security=\
BCDAdria_pass ssid=BCDAdria
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=CapsMan_DHCP_Pool ranges=10.10.252.101-10.10.252.199
/ip dhcp-server
add address-pool=CapsMan_DHCP_Pool disabled=no interface=CapsMan_Bridge name=\
CapsManDHCP
/caps-man manager
set enabled=yes
/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=CapsMan_Bridge
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=BCDAdria
/interface bridge port
add bridge=CapsMan_Bridge interface=ether2
add bridge=CapsMan_Bridge interface=ether3
add bridge=CapsMan_Bridge interface=ether4
add bridge=CapsMan_Bridge interface=ether5
/interface l2tp-server server
set caller-id-type=ip-address
/ip address
add address=10.10.252.251/24 interface=CapsMan_Bridge network=10.10.252.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.10.252.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=10.10.252.251
/ip firewall nat
add action=accept chain=srcnat ipsec-policy=out,none out-interface=ether1
/system clock
set time-zone-name=Europe/Zagreb
/system identity
set name=BCDAdria_CapsMan
/system routerboard settings
set init-delay=0s
Routing table says:
Code: Select all
0.0.0.0 / 24 ether1 reachable
10.10.252.0 /24 CapsMan_Bridge reachable
192.168.0.0 /24 ether1 reachable