Page 1 of 1

Load balancing and failover, EoIP, Bond.

Posted: Mon Feb 18, 2019 9:43 am
by antoni4321
Hello
I want to merge two channels between the head office and the branch office so that the channels work simultaneously.
If one of the Internet channels disappears, the connection works through the second channel in auto switching.
(The branch in the Internet goes through the head office)
At the head office there is 1 Internet 100 Mbps /fiber channel
In the office of branch 2 of the Internet channel 50 Mbit /fiber channel (2 ISP)
*
I set up 2 EoIP channels in the head office and branch office.
Took them into bond. (balance-rr)
*
When two internet connections are available, the two internet channels are well loaded.
if I disable any link in the branch office, packet loss begins.
router branch writes:
"
12:23:11 interface,info ether2-WAN2 link down
12:23:21 interface,info eoip-tunnel2 link down
12:23:22 interface,warning eoip-tunnel2 transmit loop detected, downing interface for 60 seconds
12:24:20 interface,info eoip-tunnel2 link up
12:24:31 interface,info eoip-tunnel2 link down
12:24:32 interface,warning eoip-tunnel2 transmit loop detected, downing interface for 60 seconds
"
In this case, the eoip-tunnel2 in the head office does not down.
*
Tell me i'm setting it right Load balancing and failover ?

<<<Scheme>>>
head office
WAN IP 5.5.5.5
second WAN IP 5.5.5.6
LAN 192.168.100.0/24
-
model = CCR1009-
RouterOS 6.43.12
/interface bridge
add fast-forward=no name=bridge1 protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] name=ether1-Wan-I1 speed=100Mbps
set [ find default-name=ether2 ] speed=100Mbps
set [ find default-name=ether3 ] speed=100Mbps
set [ find default-name=ether4 ] speed=100Mbps
set [ find default-name=ether5 ] name=ether5-LAN speed=100Mbps
set [ find default-name=ether6 ] speed=100Mbps
set [ find default-name=ether7 ] speed=100Mbps
set [ find default-name=sfp-sfpplus1 ] advertise=10M-full,100M-full,1000M-full
/interface eoip
add loop-protect=off mac-address=02:20:98:72:C9:A2 name=eoip-tunnel1 remote-address=11.11.11.10 tunnel-id=500
add loop-protect=off mac-address=02:20:98:72:C9:A2 name=eoip-tunnel2 remote-address=22.22.22.10 tunnel-id=501
/interface bonding
add mii-interval=50ms name=bonding1 slaves=eoip-tunnel1,eoip-tunnel2
/interface bridge port
add bridge=bridge1 interface=ether5-LAN
add bridge=bridge1 interface=bonding1
/ip address
add address=192.168.100.14/24 interface=ether5-LAN network=192.168.100.0
add address=5.5.5.5/27 interface=ether1-Wan-I1 network=5.5.5.0
add address=5.5.5.6/27 interface=ether1-Wan-I1 network=5.5.5.0
add address=172.16.10.29/30 interface=eoip-tunnel1 network=172.16.10.28
add address=172.16.10.33/30 interface=eoip-tunnel2 network=172.16.10.32
add address=172.16.10.41/30 interface=bonding1 network=172.16.10.40
/ip route
add distance=1 gateway=192.168.100.10
add distance=1 dst-address=11.11.11.10/32 gateway=5.5.5.1
add distance=1 dst-address=22.22.22.10/32 gateway=5.5.5.1
add distance=1 dst-address=192.168.91.0/24 gateway=172.16.10.42


branch office
model = 2011UiAS
RouterOS 6.43.12
WAN1 11.11.11.10
WAN2 22.22.22.10
LAN 192.168.91.0/24

/interface bridge
add fast-forward=no name=bridge1 protocol-mode=none
/interface bridge port
add bridge=bridge1 interface=ether5-LAN
add bridge=bridge1 interface=ether6-TestP
add bridge=bridge1 interface=bonding1

/interface eoip
add loop-protect=off mac-address=02:26:13:F5:00:56 name=eoip-tunnel1 remote-address=5.5.5.5 tunnel-id=500
add loop-protect=off mac-address=02:26:13:F5:00:56 name=eoip-tunnel2 remote-address=5.5.5.6 tunnel-id=501
/interface bonding
add mii-interval=50ms name=bonding1 slaves=eoip-tunnel1,eoip-tunnel2

/ip address
add address=11.11.11.10/30 interface=sfp1-WAN1 network=11.11.11.8
add address= 22.22.22.10/30 interface=ether2-WAN2 network=22.22.22.8
add address=192.168.91.2/24 interface=ether5-LAN network=192.168.91.0
add address=172.16.10.30/30 interface=eoip-tunnel1 network=172.16.10.28
add address=172.16.10.34/30 interface=eoip-tunnel2 network=172.16.10.32
add address=172.16.10.42/30 interface=bonding1 network=172.16.10.40

/ip route
add distance=1 gateway=172.16.10.41
add distance=1 dst-address=5.5.5.5/32 gateway=11.11.11.9
add distance=1 dst-address=5.5.5.3/32 gateway=22.22.22.9

Re: Load balancing and failover, EoIP, Bond.

Posted: Mon Feb 18, 2019 6:48 pm
by vklpt
/interface eoip
add loop-protect=off mac-address=02:20:98:72:C9:A2 name=eoip-tunnel1 remote-address=11.11.11.10 tunnel-id=500
add loop-protect=off mac-address=02:20:98:72:C9:A2 name=eoip-tunnel2 remote-address=22.22.22.10 tunnel-id=501
/interface eoip
add loop-protect=off mac-address=02:26:13:F5:00:56 name=eoip-tunnel1 remote-address=5.5.5.5 tunnel-id=500
add loop-protect=off mac-address=02:26:13:F5:00:56 name=eoip-tunnel2 remote-address=5.5.5.6 tunnel-id=501
I'm not shure if it actual reason of failure but better not use same mac-addresses for different interfaces.
And stateless interfaces like EOIP not so reliable in my experience, i think better use L2TP with routing.

Re: Load balancing and failover, EoIP, Bond.

Posted: Mon Feb 18, 2019 9:30 pm
by sebastia
Hey

Make sure you have link monitoring configured using arp, since you route to your remote destination: https://wiki.mikrotik.com/wiki/Manual:I ... monitoring


You modified config by hand before post ;-)?

e=eoip-tunnel2 remote-address=5.5.5.6 tunnel-id=501
&
1 dst-address=5.5.5.3/32 gateway=22.22.22.9

Re: Load balancing and failover, EoIP, Bond.

Posted: Tue Feb 19, 2019 6:26 am
by antoni4321
Hey

Make sure you have link monitoring configured using arp, since you route to your remote destination: https://wiki.mikrotik.com/wiki/Manual:I ... monitoring


You modified config by hand before post ;-)?

e=eoip-tunnel2 remote-address=5.5.5.6 tunnel-id=501
&
1 dst-address=5.5.5.3/32 gateway=22.22.22.9

Hello
sebastia, thanks for the advice!
I changed the link-monitoring,
Setting the address in the bond EoIP point.
*
head office
/interface bonding
add arp-ip-targets=172.16.10.30,172.16.10.34 link-monitoring=arp mii-interval=50ms name=bonding1 slaves=eoip-tunnel1,eoip-tunnel2

branch office
/interface bonding
add arp-ip-targets=172.16.10.29,172.16.10.33 link-monitoring=arp mii-interval=50ms name=bonding1 slaves=eoip-tunnel1,eoip-tunnel2
*

With such settings, there is a slight packet handling
until EoIP tun in branch office falls.

>>
09:31:34 interface,info ether2-WAN2 link down
09:33:14 interface,info eoip-tunnel2 link down
09:38:58 interface,info ether2-WAN2 link up (speed 1G, full duplex)
09:38:58 interface,info eoip-tunnel2 link up
09:56:30 interface,info sfp1-WAN1 link down
09:58:09 interface,info eoip-tunnel1 link down
10:10:35 interface,info sfp1-WAN1 link up (speed 1G, full duplex)
10:10:36 interface,info eoip-tunnel1 link up
<<

Re: Load balancing and failover, EoIP, Bond.

Posted: Wed Feb 20, 2019 10:51 pm
by sebastia
You shouldn't assign ip's to eoip tunnel (requirement of bonding) and you should use the bonding interface ip for arp check, so .41 & .42.