Question about recent VLAN post "VLAN your network"
Posted: Wed Mar 27, 2019 7:15 pm
Been reading pcunite's work on VLANs.
viewtopic.php?f=13&t=143620
I have a question about "Switch with a separate router (RoaS)". I understand why these examples fully VLAN all traffic. However, in my small system, I'd prefer to mix in untagged traffic as slightly more trusted, and keep IOT and guest WLAN on VLANs. I'm not clear on how this would change the configuration.
My assumptions for changing the "blue" ports to untagged:
# Purple Trunk. These need IP Services (L3), so add Bridge as member
add bridge=BR1 untagged=BR1,ether2,ether3,ether4,ether5,ether6,ether7,sfp1
add bridge=BR1 tagged=BR1,ether2,ether3,ether4,ether5,ether6,ether7,sfp1 vlan-ids=20
add bridge=BR1 tagged=BR1,ether2,ether3,ether4,ether5,ether6,ether7,sfp1 vlan-ids=30
# Blue VLAN interface creation, IP assignment, and DHCP service
/interface vlan add interface=BR1 name=BLUE_LAN
/ip address add interface=BLUE_LAN address=10.0.10.1/24
/ip pool add name=BLUE_POOL ranges=10.0.10.2-10.0.10.254
/ip dhcp-server add address-pool=BLUE_POOL interface=BLUE_LAN name=BLUE_DHCP disabled=no
/ip dhcp-server network add address=10.0.10.0/24 dns-server=192.168.0.1 gateway=10.0.10.1
viewtopic.php?f=13&t=143620
I have a question about "Switch with a separate router (RoaS)". I understand why these examples fully VLAN all traffic. However, in my small system, I'd prefer to mix in untagged traffic as slightly more trusted, and keep IOT and guest WLAN on VLANs. I'm not clear on how this would change the configuration.
My assumptions for changing the "blue" ports to untagged:
# Purple Trunk. These need IP Services (L3), so add Bridge as member
add bridge=BR1 untagged=BR1,ether2,ether3,ether4,ether5,ether6,ether7,sfp1
add bridge=BR1 tagged=BR1,ether2,ether3,ether4,ether5,ether6,ether7,sfp1 vlan-ids=20
add bridge=BR1 tagged=BR1,ether2,ether3,ether4,ether5,ether6,ether7,sfp1 vlan-ids=30
# Blue VLAN interface creation, IP assignment, and DHCP service
/interface vlan add interface=BR1 name=BLUE_LAN
/ip address add interface=BLUE_LAN address=10.0.10.1/24
/ip pool add name=BLUE_POOL ranges=10.0.10.2-10.0.10.254
/ip dhcp-server add address-pool=BLUE_POOL interface=BLUE_LAN name=BLUE_DHCP disabled=no
/ip dhcp-server network add address=10.0.10.0/24 dns-server=192.168.0.1 gateway=10.0.10.1