Page 1 of 1

ovpn-client and "IP packet with unknown IP version=0 seen"

Posted: Fri Mar 29, 2019 11:36 am
by hhoeth
Hi!

I'm using /interface ovpn-client to connect to an openvpn server running on a Debian box. After upgrading from 6.43.7 to 6.44 my server logs are flooded with messages like this:
IP packet with unknown IP version=0 seen
The server is running openvpn-2.4.0-6+deb9u3. The client config is:
/interface ovpn-client
add certificate=client.crt_0 cipher=aes256 connect-to=XXXXXXXXXXXXXXXXXXXXXXX.com mac-address=FE:DA:87:73:D7:6D name=v-0001 port=1195 user=nobody
The server config of one server is
mode server
tls-server
keepalive 10 60
status server.log

dev tun

proto tcp-server

local XXX.XXX.XXX.XXX
port 1195

cipher AES-256-CBC

user openvpn
group openvpn
persist-key
persist-tun

ca /path/to/ca.crt
cert /path/to/server.crt
key /path/to/server.key
dh /path/to/dh.pem

topology subnet
server 192.168.32.0 255.255.224.0

ccd-exclusive
client-config-dir /path/to/ips/

client-to-client

script-security 2
learn-address "/usr/bin/sudo /path/to/learn-address.sh"
I've got another server with the same problem and the following config:
mode server
tls-server
keepalive 30 240
status /var/log/openvpn/tcp.log

dev tun

proto tcp-server

local XXX.XXX.XXX.XXX
port 1194

cipher AES-256-CBC

user openvpn
group openvpn
chroot /etc/openvpn/server/ips
persist-key
persist-tun

pkcs12 /etc/openvpn/server/server/XXXX.p12
dh     /etc/openvpn/server/server/dh4096.pem

ifconfig 10.1.0.1 10.1.0.254
route 10.1.0.0 255.255.0.0

push "route 10.0.0.0 255.255.0.0"
push "route 10.1.0.0 255.255.0.0"

ccd-exclusive
client-config-dir ./tcp/ # this is relative to the chroot
I haven't touched the configuration of either the servers or the clients. The only change was upgrading RouterOS. And I haven't seen any openvpn related entries in the changelogs. Any idea what's going on here?

Cheers,

Hendrik

Re: ovpn-client and "IP packet with unknown IP version=0 seen"

Posted: Tue Apr 02, 2019 11:45 am
by hhoeth
I downgraded to 6.43.13 now, and the log messages are gone. I hope this gets fixed in stable.

Re: ovpn-client and "IP packet with unknown IP version=0 seen"

Posted: Thu May 30, 2019 11:02 am
by dibatech
Seeing the same.
CCR1009
6.44.3
IP packet with unknown IP version=0 seen

Re: ovpn-client and "IP packet with unknown IP version=0 seen"

Posted: Sun Aug 18, 2019 12:44 am
by hhoeth
This fixed it for me:
/ip neighbor discovery-settings set discover-interface-list=none

Re: ovpn-client and "IP packet with unknown IP version=0 seen"

Posted: Wed Sep 11, 2019 4:31 pm
by Becache
This fixed it for me:
/ip neighbor discovery-settings set discover-interface-list=none
Thank you. It is worked.