I am trying to relearn MT and I am trying this loadbalancing from a tutorial..
https://aacable.wordpress.com/2011/07/2 ... t-by-zaib/
Basically its the same as the PCC in the wiki mikrotik..
Well my question sir is, I followed everything what is in the mangle.. I just used whatever router variables I have and then replaced them
on the code..
The thing sir is this code working?
https://drive.google.com/file/d/1E0WwE5 ... sp=sharing
as I was testing the configuration.. the part highlighted doesnt have any activity.. or packets or bytes going through that
part of the mangle..
Also I noticed that when I speedtest or test download a file to see if it loadbalance or what.. I only see one interface carrying all of the
load.. cause its the only one raising the numbers.. and the other interface remains dormant.. it spikes sometimes.. only in kb and after several tries and multiple
download.. the other interface finally gets an activity.. the highest I saw was 5Mb.. but only for only a few seconds..
When its supposed to like share the load on both interface right sir??
Can anyone guide me sirs?? im totally noob with these.. I already read the manual and followed the case study.. but I just dont
seem to get it.. any hint sirs??
Heres the current config I have..
Code: Select all
/interface ethernet
set [ find default-name=ether1 ] comment=CONVERGE
set [ find default-name=ether2 ] comment=SKY
set [ find default-name=ether3 ] comment="ISP Reserve" disabled=yes
set [ find default-name=ether4 ] comment="LAN RESERVE" master-port=ether5
/interface bridge port
add bridge=bridge-LAN interface=ether5
/ip address
add address=192.168.3.1/24 comment="LAN bridge" interface=bridge-LAN network=\
192.168.3.0
/ip dhcp-client
add comment=Internet dhcp-options=hostname,clientid disabled=no interface=\
ether1
add add-default-route=no dhcp-options=hostname,clientid disabled=no \
interface=ether2 use-peer-dns=no use-peer-ntp=no
/ip dhcp-server network
add address=192.168.3.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.3.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall mangle
add action=mark-connection chain=input comment="PCC LOAD BALANCE SETTINGS" \
in-interface=ether1 new-connection-mark=WAN1_conn passthrough=yes
add action=mark-connection chain=input in-interface=ether2 \
new-connection-mark=WAN2_conn passthrough=yes
add action=mark-routing chain=output connection-mark=WAN1_conn \
new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn \
new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 in-interface=bridge-LAN
add chain=prerouting dst-address=192.168.2.0/24 in-interface=bridge-LAN
add action=mark-connection chain=prerouting comment="PCC Marking" \
dst-address-type=!local in-interface=bridge-LAN new-connection-mark=\
WAN1_conn passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=bridge-LAN new-connection-mark=WAN2_conn passthrough=yes \
per-connection-classifier=both-addresses:2/1
add action=mark-routing chain=prerouting comment="routing mark to isp1" \
connection-mark=WAN1_conn in-interface=bridge-LAN new-routing-mark=\
to_WAN1 passthrough=no
add action=mark-routing chain=prerouting comment="routing mark to isp2" \
connection-mark=WAN2_conn in-interface=bridge-LAN new-routing-mark=\
to_WAN2 passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat comment=ISP1 out-interface=ether1 \
src-address-list=local
add action=masquerade chain=srcnat comment=ISP2 out-interface=ether2 \
src-address-list=local
/ip route
add check-gateway=ping comment=SKY distance=1 gateway=192.168.2.1
add check-gateway=ping comment=Converge distance=1 gateway=192.168.1.1