It is not clear from your question whether you want to set this up on a Mikrotik or on some other DHCP server. On Mikrotik, the embedded help tells you what to do:
[me@MyTik] > ip dhcp-server network add address=192.168.115.0/24 dns-server=[?]
Server ::= Address[,Server] (max 100 times)
Address ::= A.B.C.D (IP address)
so the whole command to define 192.168.19.1 and 192.168.33.1 as primary and secondary DNS server would be
/ip dhcp-server network add address=reserved.ip.for.the.client/32 dns-server=192.168.19.1,192.168.33.1
If you are configuring some exotic DHCP server which doesn't recognize the DNS server option by name, RFC2302 has the answer:
3.7. Name Server Option
The name server option specifies a list of IEN 116 [7] name servers available to the client. Servers SHOULD be listed in order of preference.
The code for the name server option is 5. The minimum length for this option is 4 octets, and the length MUST always be a multiple of 4.
...
So using the RouterOS way of defining DHCP options, you would use
/ip dhcp-server option add name=dns code=5 value=0xc0a81301c0a82101 to define primary server 192.168.19.1 and secondary server 192.168.33.1.