The purpose is to be able to use any port (ether2-5) to access the hEX and also to be able to use the same ports for PPPoE if required.
I might have done the pppoe_bridge wrong because of lack of knowledge.
Here is the setup:
Code: Select all
/interface bridge
add arp=proxy-arp name=bridge_pppoe protocol-mode=none
/interface vlan
add interface=ether2 name=vlan7_ether2 vlan-id=7
add interface=ether3 name=vlan7_ether3 vlan-id=7
add interface=ether4 name=vlan7_ether4 vlan-id=7
add interface=ether5 name=vlan7_ether5 vlan-id=7
/ip pool
add name=pppoe-pool ranges=192.168.200.2-192.168.200.254
/ppp profile
add local-address=192.168.200.1 name=pppoe-profile remote-address=pppoe-pool
/interface bridge port
add bridge=bridge_pppoe interface=vlan7_ether2
add bridge=bridge_pppoe interface=vlan7_ether3
add bridge=bridge_pppoe interface=vlan7_ether4
add bridge=bridge_pppoe interface=vlan7_ether5
/interface pppoe-server server
add authentication=pap default-profile=pppoe-profile disabled=no interface=\
bridge_pppoe one-session-per-host=yes service-name=TestPPPoE
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN src-address=\
192.168.200.0/24
/ppp secret
add name=testuser password=test profile=pppoe-profile service=pppoe
PPPoE over VLAN7 and accessing the hEX without VLAN7 works quite well. However when being on any of the PPPoE clients DNS lookup doesn't work.
Code: Select all
dig @192.168.200.1 google.com
or
dig @192.168.88.1 google.com
Using an external DNS server is not a problem and works instantly. However I would prefer not to have to specify an external server (the hEX already does know how to do DNS lookups).
How can I fix this?