Multiple WAN and Web Servers
Posted: Mon Mar 09, 2020 10:01 pm
Hi there,
I have an RB3011UiAS and a big problem...
I have multiple external IP addresses on multiple WAN ports, one address for each port. Reason: my ISP can only assign one IP address per MAC...
Second, I have multiple servers behind it, two of them are web servers. And no, they can't be on the same machine, because one is Linux, the other on Windows.
What I want to do is the following:
WAN Port 1 -> Web Server 1
WAN Port 2 -> Web Server 2
the first web server is working, the second one not.
The router is currently resetted without default config.
Here's what I have now:
another challenge: I don't have fixed IP addresses from the ISP, so everything is DHCP.
I understand that srcnat should solve my problem, but:
.) I haven't got it to work
.) the external IP address must be dynamic, so everything has to be solved with interfaces...
Please help a noob![Smile :)](./images/smilies/icon_smile.gif)
needless to say: I'm a bloody beginner![Smile :)](./images/smilies/icon_smile.gif)
I have an RB3011UiAS and a big problem...
I have multiple external IP addresses on multiple WAN ports, one address for each port. Reason: my ISP can only assign one IP address per MAC...
Second, I have multiple servers behind it, two of them are web servers. And no, they can't be on the same machine, because one is Linux, the other on Windows.
What I want to do is the following:
WAN Port 1 -> Web Server 1
WAN Port 2 -> Web Server 2
the first web server is working, the second one not.
The router is currently resetted without default config.
Here's what I have now:
Code: Select all
MikroTik RouterOS 6.46.4 (c) 1999-2020 http://www.mikrotik.com/
# model = RouterBOARD 3011UiAS
/ip address
add address=192.168.0.4/24 interface=ether10 network=192.168.0.0
/ip dhcp-client
add disabled=no interface=ether1
add disabled=no interface=ether2
add disabled=no interface=ether3
/ip firewall nat
add action=dst-nat chain=dstnat comment="WebServer1 HHTP" dst-port=80 in-interface=ether1 log=yes protocol=tcp to-addresses=192.168.0.32
add action=dst-nat chain=dstnat comment="WebServer1 HHTPS" dst-port=443 in-interface=ether1 log=yes protocol=tcp to-addresses=192.168.0.32
add action=dst-nat chain=dstnat comment="WebServer2 HHTP" dst-port=80 in-interface=ether3 log=yes protocol=tcp to-addresses=192.168.0.15
add action=dst-nat chain=dstnat comment="WebServer2 HHTPS" dst-port=443 in-interface=ether3 protocol=tcp to-addresses=192.168.0.15
I understand that srcnat should solve my problem, but:
.) I haven't got it to work
.) the external IP address must be dynamic, so everything has to be solved with interfaces...
Please help a noob
![Smile :)](./images/smilies/icon_smile.gif)
needless to say: I'm a bloody beginner
![Smile :)](./images/smilies/icon_smile.gif)