Well, yes I was going access two vlans over the EOIP tunnel. ...
Maybe I do not need an EOIP over SSTP configuration..?
If you use the single-bridge-for-all-vlans approach with
vlan-filtering=yes on the bridge, you cannot attach the BCP L2 tunnel directly to that
br-all-vlans, because this dynamic addition does not support
vlan-filtering=yes (at least it didn't a year ago).
So you can either use the EoIP tunnel as you've planned, or you can save some overhead bytes (= link bandwidth and likely also some CPU) by using 802.1ad service-vlan tagging to transport a trunk of 802.1Q customer-vlans:
bcp tunnel <-> br-s-vlan(0x88a8) <-> (T)br-s-vlan.7(U) <-> br-all-vlans(0x8100)
The corresponding commands would look as follows (at both the SSTP server side and SSTP client side):
/interface bridge add name=br-s-vlan vlan-filtering=no ether-type=0x88a8
/interface vlan add name=br-s-vlan.7 interface=br-s-vlan use-service-tag=yes vlan-id=7
/interface bridge port add bridge-br-all-vlans interface=br-s-vlan.7
.....a generic command would be too complex, so in plain words: add the
br-s-vlan.7 to the
tagged list of all rows of
/interface bridge vlan whose
vlan-ids contain the VLANs you want to transport via the tunel...
/ppp profile add copy-from=default-encryption name=sstp-s-bridge bridge=br-s-vlan
On the SSTP server side only:
/ppp secret set <your-secret-name> profile=sstp-s-bridge
On the SSTP client side only
/interface sstp-client set <your-interface-name> profile=sstp-s-bridge
Furthermore, when the remote office PC1 is connected to HQ vlan; I want the vlan traffic for
PC1 connected to vlans to stay on the vlan gateway (which it does by default) then... when
PC1 sends traffic outside of the vlan to the public WAN... I want to use a different gateway (ISP)
so that PC1 is not consuming bandwidth from HQ for surfing or doing traffic not related to vlans...
Rather, PC1 uses its own ISP provider bandwidth for non-related vlan traffic.
Well, let's first differentiate between "gateway", "route", and the misleading shortcut "default gateway" which actually means "default route's gateway".
To talk to other devices inside its own IP subnet (which typically maps 1:1 to a VLAN ID but it is not a law of physics), a device needs no gateway as these are reachable directly on L2. So routes with one of own subnets as destination have the corresponding interface itself as a gateway. Such subnets are called "connected" ones.
To talk to devices outside connected subnets, the device needs to send the packets via a router device in one of the connected subnets (a gateway router), so the routes to these destinations indicate IP addresses of these routers as gateways. And one of the routes may be a default one (which is used if no other route matches more narrowly). And since many end devices, like the PCs, have no other routes configured, the shortcut became known as "default gateway" (because you only have to configure the gateway information, whereas the
dst-address=0.0.0.0/0 part is implicit).
So... as long as you only need the PC to talk to other devices in the same VLAN/subnet where it is connected via the tunnel, and to the rest of the world via the WAN of the Mikrotik to which it is connected, what I wrote earlier is enough - the default gateway for that PC will be the own IP address, in the subnet where the PC is connected, of the Mikrotik where the PC is connected, and that's it (so the Mikrotik at each end of the tunnel must have its own IP in each of the two subnets which live in each of the two VLANs).
If you want that the PC at the BO end can access also some other, non-connected, subnets in the HQ network via the VLAN tunnel, the situation is more complex. If you add these routes to the BO Mikrotik itself, what should happen is that the PC sends the packet to the BO Mikrotik, the BO Mikrotik determines that the in-interface and out-interface of the packet are the same, so it sends an ICMP notification about a better gateway to the PC, which should accept it and send the packet to the HQ Mikrotik (and cache this for a while so it will send the subsequent packets via the HQ mikrotik straight away). So try this first, and if it doesn't help, come back, I'll write something regarding dynamic configuration of client's routing tables using DHCP.