Do anyone have any inputs on why I could be having this problem?
We are building a NDI based studio center with 3 studios. And have bought mikrotik switches for 8000$ to have as the backbone for this center, with 40gbit/s fiber uplink in a ring of 48p poe switches, etc.
The problem is that the switches seem to start to send data in bursts, or if I shoud believe my wireshark dump, also duplicate packets across switches.
If I am connected with my computer, or a Newtek NDI Spark Plus NDI to HDMI converter to the same switch (CRS312) as the newtek mixer, the video flows great, and there is no problems.
The bridge is hardware offloaded on both switches, all ports are hardware offloaded. The ports in question is on vlan 42, and between the switches, trunk is set up, where 42 is one of the vlans that is transferred between the switches.
Traffic with small packets flow great. Such as audio over DANTE, etc. No issues. But big packet data like NDI is having problems when each stream is using > 150mbit/s. NDI is flowing via TCP at this time, because UDP packets is behaving even worse and don't work at all. The newtek mixer is connected via 10gbit copper, and at the time, the switches are connected with a 10GBit/s copper pigtail (MO-S+DA001), but I have also tried with 1gigabit copper sfp's from mikrotik, and it does nothing to help.
I am running latest stable on both switches. But I have tried testing release too. But if anything it was worse with testing.
I have a wireshark pcap if anyone wants to look at it. I feel like I have tested everything. And at this state. Any normal dumb switch would have worked better than our mikrotik switches. So we hope we haven't bought a bunch of scrap metal :( We have enjoyed using RB750 for years, and the CRS switches for routing. And love using mikrotik in that regards. But at this time, we are having big issues with the CRS312 and CRS354 switches working together as normal switches with a little bit of VLAN tagging.
Here is the config on the CRS312, and the config is the same on the CRS354 switches, just with more ports and trunk ports:
Code: Select all
/export hide-sensitive
# sep/25/2020 22:28:17 by RouterOS 6.47.4
# software id = S53Z-P5GU
#
# model = CRS312-4C+8XG
# serial number = AE060B1321C4
/interface bridge
add igmp-snooping=yes mtu=1500 name=main-bridge pvid=30 vlan-filtering=yes
/interface ethernet
set [ find default-name=combo1 ] name=ether9-sfpp1
set [ find default-name=combo2 ] name=ether10-sfpp2
set [ find default-name=combo3 ] name=ether11-sfpp3
set [ find default-name=combo4 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full,2500M-full,5000M-full,10000M-full name=ether12-sfpp4
set [ find default-name=ether9 ] name=etherMGMT
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/user group
set full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api,romon,dude,tikapp
/interface bridge port
add bridge=main-bridge interface=ether9-sfpp1 pvid=41
add bridge=main-bridge interface=ether10-sfpp2 pvid=41
add bridge=main-bridge interface=ether11-sfpp3 pvid=30
add bridge=main-bridge interface=ether12-sfpp4 pvid=30
add bridge=main-bridge interface=etherMGMT pvid=30
add bridge=main-bridge interface=ether1 pvid=42
add bridge=main-bridge interface=ether2 pvid=42
add bridge=main-bridge interface=ether3 pvid=42
add bridge=main-bridge interface=ether4 pvid=41
add bridge=main-bridge interface=ether5 pvid=41
add bridge=main-bridge interface=ether6 pvid=42
add bridge=main-bridge interface=ether7 pvid=42
add bridge=main-bridge interface=ether8 pvid=42
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface bridge vlan
add bridge=main-bridge comment=MANAGEMENT untagged=etherMGMT vlan-ids=30
add bridge=main-bridge comment=HOST tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=41
add bridge=main-bridge comment=NDI tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=42
add bridge=main-bridge comment=DANTE tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=43
add bridge=main-bridge comment=AES67 tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=44
add bridge=main-bridge comment=COM tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=45
add bridge=main-bridge comment=KVM tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=46
add bridge=main-bridge comment=CONTROL tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=47
add bridge=main-bridge comment=GUEST tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=48
add bridge=main-bridge comment=OSSWAN tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=40
add bridge=main-bridge comment=ARTNET tagged=ether9-sfpp1,ether10-sfpp2,ether11-sfpp3,ether12-sfpp4 vlan-ids=49
/ip address
add address=10.22.2.103/24 interface=main-bridge network=10.22.2.0
/ip dns
set servers=1.1.1.1
/ip route
add distance=1 gateway=10.22.2.1
/system clock
set time-zone-name=Europe/Oslo
/system identity
set name=SHP4.5.0-SW2
/system routerboard settings
set boot-os=router-os