The plan is to run a two routers as master/slave, both with hotspot running for guest users. I've configured it as I thought it should be, however when I create a hotspot and set it to run on the vrrp interface, although the client connects and receives an IP address, the device does not show up in the hotspot and the user cannot reach anything or the splash page. If I set the hotspot to run the ethernet interface then this shows up correctly, but I don't know how that will work with vrrp. It's like hotspot cannot be enabled on a vrrp interface at the same time?
Note that the hotspot address is set to the vrrp address because I want the default gateway/dns for clients to be the vrrp interface in case we need to fail over to the slave...
Config below:
ether2 - uplink to WAN (dhcp)
ether3 - vrrp and hotspot
Code: Select all
/interface vrrp
add interface=ether3 name=vrrp-standard vrid=16
/ip hotspot profile
add hotspot-address=192.168.23.254 login-by=http-pap name=hs-profile-standard
/ip pool
add name=hs-pool-standard ranges=192.168.16.20-192.168.19.254
/ip dhcp-server
add address-pool=hs-pool-standard disabled=no interface=vrrp-standard lease-time=15m name=dhcp-standard
/ip hotspot
add address-pool=hs-pool-standard addresses-per-mac=unlimited disabled=no idle-timeout=none interface=vrrp-standard name=standard profile=hs-profile-standard
/ip address
add address=192.168.16.11 interface=ether3 network=255.255.248.0
add address=192.168.23.254 interface=vrrp-standard network=255.255.255.255
/ip dhcp-client
add disabled=no interface=ether2
/ip dhcp-server network
add address=192.168.16.0/21 comment="hotspot network - standard" dns-server=192.168.23.254 gateway=192.168.23.254
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=192.168.16.0/21
/ip hotspot user
add name=admin
Code on the second router is the same apart from a different IP address for ether3 and a different dhcp pool to avoid ip conflicts/confusion if it fails over.
Any help would be appreciated.
Thanks
James