MTK L2TP clients do not get DNS servers from PPP profile
Posted: Fri Feb 26, 2021 6:15 pm
Hello everyone,
I have configured some hEX routers as L2TP/IPsec client of a Mikrotik CHR server and they work very well.
The problem is that they don't get the DNS server addresses I specified in the profile, the same one used to configure the server too.
With the same server configuration, Windows clients get DNS server addresses without any problems.
To get around the problem at the moment on the client side I am using Netwatch to swap public and private DNS servers, monitoring if the internal DNS server is reachable via VPN or not.
This is the relevant server-side configuration:
This is the client one (basically the default one):
I searched a lot in the forum but the only recurring problem I found concerns the configuration of the DNS suffix, which in my case is not a problem.
Suggestions?
I have configured some hEX routers as L2TP/IPsec client of a Mikrotik CHR server and they work very well.
The problem is that they don't get the DNS server addresses I specified in the profile, the same one used to configure the server too.
With the same server configuration, Windows clients get DNS server addresses without any problems.
To get around the problem at the moment on the client side I am using Netwatch to swap public and private DNS servers, monitoring if the internal DNS server is reachable via VPN or not.
This is the relevant server-side configuration:
Code: Select all
/ip address add address=172.16.0.1/24 interface=ether2 network=172.16.0.0
/ppp profile add dns-server=172.16.0.1 local-address=172.18.0.254 name=l2tp-profile
/ppp secret add name=myclient password=*** profile=l2tp-profile remote-address=172.18.0.51 routes="172.16.51.0/24 172.18.0.51 1" service=l2tp
/interface l2tp-server server set allow-fast-path=yes authentication=mschap1,mschap2 default-profile=l2tp-profile enabled=yes ipsec-secret=*** use-ipsec=required
This is the client one (basically the default one):
Code: Select all
/interface l2tp-client add add-default-route=yes connect-to=my.vpn.server.address disabled=no ipsec-secret=*** name=myserver password=*** use-ipsec=yes user=myclient
/ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
I searched a lot in the forum but the only recurring problem I found concerns the configuration of the DNS suffix, which in my case is not a problem.
Suggestions?