rtrA is the new RB4011. rtrB is an existing 750G. Logs show that rtrA creates the initial packet, sends it, rtrB receives it, processes, replies to rtrA. Reply reaches rtrA, is detected by packet sniffer but not registered by firewall or ipsec stack. Both routers have public, static IPs.
Has anyone else encountered anything similar? What next steps can I do to debug this? Any help appreciated :).
Code: Select all
[rok@rtrA] /system routerboard> /system routerboard print
routerboard: yes
model: RB4011iGS+
revision: r2
serial-number: XXX
firmware-type: al2
factory-firmware: 6.45.9
current-firmware: 6.45.9
upgrade-firmware: 6.48.1
[rok@rtrA] /ip ipsec> export
# mar/15/2021 01:33:48 by RouterOS 6.48.1
# software id = 5ZRG-3PM4
# model = RB4011iGS+
# serial number = XXX
/ip ipsec peer
add address=BB.BBB.BBB.BBB/32 exchange-mode=ike2 name=rtrB
/ip ipsec profile
set [ find default=yes ] dh-group=modp2048 dpd-interval=5m enc-algorithm=aes-256 hash-algorithm=sha256 name=profile_1
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha256 enc-algorithms=aes-256-cbc pfs-group=modp2048
/ip ipsec identity
add my-id=fqdn:rtrA peer=rtrB secret=XXX
/ip ipsec policy
set 0 disabled=yes
add dst-address=10.X.X.0/24 peer=rtrB sa-dst-address=BB.BBB.BBB.BBB sa-src-address=0.0.0.0 src-address=10.YY.YY.0/24 tunnel=yes
[rok@rtrA] /ip firewall raw> /tool sniffer packet print
# TIME INTERFACE SRC-ADDRESS DST-ADDRESS IP-PROTOCOL SIZE CPU FP
0 7.052 WAN AA.AAA.AA.AAA:4500 BB.BBB.BBB.BBB:4500 udp 478 3 no
1 7.925 WAN BB.BBB.BBB.BBB:4500 AA.AAA.AA.AAA:4500 udp 470 1 no
2 12.058 WAN AA.AAA.AA.AAA:4500 BB.BBB.BBB.BBB:4500 udp 478 3 no
3 12.112 WAN BB.BBB.BBB.BBB:4500 AA.AAA.AA.AAA:4500 udp 470 1 no
4 17.064 WAN AA.AAA.AA.AAA:4500 BB.BBB.BBB.BBB:4500 udp 478 3 no
5 17.118 WAN BB.BBB.BBB.BBB:4500 AA.AAA.AA.AAA:4500 udp 470 1 no
6 22.059 WAN AA.AAA.AA.AAA:4500 BB.BBB.BBB.BBB:4500 udp 478 3 no
7 22.116 WAN BB.BBB.BBB.BBB:4500 AA.AAA.AA.AAA:4500 udp 470 1 no
[rok@rtrA] /ip firewall raw> /ip firewall raw print stats
Flags: X - disabled, I - invalid, D - dynamic
# CHAIN ACTION BYTES PACKETS
0 D ;;; special dummy rule to show fasttrack counters
prerouting passthrough 177 028 927 163 150
1 prerouting accept 0 0
2 prerouting accept 115 256 402
[...]
[rok@rtrA] /ip firewall raw> print
Flags: X - disabled, I - invalid, D - dynamic
0 D ;;; special dummy rule to show fasttrack counters
chain=prerouting action=passthrough
1 chain=prerouting action=accept src-port=4500 dst-port=4500 protocol=udp src-address=BB.BBB.BBB.BBB
2 chain=prerouting action=accept src-address=BB.BBB.BBB.BBB
[rok@rtrA] /ip firewall raw> /log print where message~"received" or message~"sending"
01:04:52 ipsec,debug IPSEC: ===== sending 432 bytes from AA.AAA.AA.AAA[4500] to BB.BBB.BBB.BBB[4500]
01:04:57 ipsec,debug IPSEC: ===== sending 432 bytes from AA.AAA.AA.AAA[4500] to BB.BBB.BBB.BBB[4500]
01:05:02 ipsec,debug IPSEC: ===== sending 432 bytes from AA.AAA.AA.AAA[4500] to BB.BBB.BBB.BBB[4500]
01:05:17 ipsec,debug IPSEC: ===== sending 432 bytes from AA.AAA.AA.AAA[4500] to BB.BBB.BBB.BBB[4500]
[rok@rtrB] /ip ipsec statistics> /log print where message~"received" or message~"sending"
02:08:22 ipsec,debug IPSEC: ===== sending 424 bytes from BB.BBB.BBB.BBB[4500] to AA.AAA.AA.AAA[4500]
02:08:27 ipsec,debug IPSEC: ===== received 432 bytes from AA.AAA.AA.AAA[4500] to BB.BBB.BBB.BBB[4500]
02:08:27 ipsec,debug IPSEC: ===== sending 424 bytes from BB.BBB.BBB.BBB[4500] to AA.AAA.AA.AAA[4500]
02:08:32 ipsec,debug IPSEC: ===== received 432 bytes from AA.AAA.AA.AAA[4500] to BB.BBB.BBB.BBB[4500]