VLAN Routing is slow on hex S
Posted: Fri Jun 04, 2021 1:25 pm
Hi,
I have a hex S and a CSS326 and using VLANs. This works so far, but the traffic between two VLANs is very slow (50 mb/s) and the CPU usage of the hex S is at 40-60 %.
Where is the error in the config?
Where's the problem?
Eth1 is connected to modem
Eth2 is connected to CSS
Eth3 is connected to CSS
Eth4 is directly connected to a NIC for DMZ
Eth5 is connected to CSS
Eth3 and Eth5 are linked together als a bond
I have a hex S and a CSS326 and using VLANs. This works so far, but the traffic between two VLANs is very slow (50 mb/s) and the CPU usage of the hex S is at 40-60 %.
Where is the error in the config?
Code: Select all
# jun/04/2021 12:18:29 by RouterOS 6.48.2
# software id = XE0V-A40Q
#
# model = RB760iGS
# serial number = xxxxxxx
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether2 ] name="ether2(WLAN)"
set [ find default-name=sfp1 ] disabled=yes
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan30 vlan-id=30
add interface=bridge1 name=vlan50 vlan-id=1
/interface bonding
add mode=802.3ad name=bonding1 slaves=ether3,ether5
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip firewall layer7-protocol
add name="Block Site" regexp="^.+(facebook).*\$"
/ip pool
add name=dhcp ranges=192.168.0.20-192.168.0.40
add name=dhcp_pool6 ranges=192.168.20.2-192.168.20.254
add name=dhcp_pool10 ranges=192.168.10.2-192.168.10.254
add name=DMZ ranges=192.168.100.2-192.168.100.254
add name=dhcp_pool12 ranges=192.168.30.2-192.168.30.254
add name=WLAN ranges=192.168.50.3-192.168.50.100
add name=" pool-vpn" ranges=192.168.123.100-192.168.123.199
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 lease-script=\
dhcp-lease-script lease-time=2h name=server1
add address-pool=dhcp_pool6 disabled=no interface=vlan20 name=dhcp2
add address-pool=DMZ disabled=no interface=ether4 name=dhcp3
add address-pool=dhcp_pool10 disabled=no interface=vlan10 lease-script=\
dhcp-lease-script name=dhcp4
add address-pool=dhcp_pool12 disabled=no interface=vlan30 lease-time=4d4h10m \
name=dhcp1
add address-pool=WLAN disabled=no interface="ether2(WLAN)" name=WLAN
/port
set 0 name=serial0
/ppp profile
add dns-server=192.168.123.254 local-address=192.168.123.254 name=vpn \
remote-address=" pool-vpn" use-compression=no use-encryption=required
/user group
set full policy="local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,pas\
sword,web,sniff,sensitive,api,romon,dude,tikapp"
/dude
set enabled=yes
/interface bridge port
add bridge=bridge1 interface=bonding1
add bridge=bridge1 disabled=yes interface="ether2(WLAN)" pvid=50
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,bonding1 vlan-ids=10
add bridge=bridge1 tagged=bridge1,bonding1 vlan-ids=20
add bridge=bridge1 tagged=bridge1,bonding1 vlan-ids=30
add bridge=bridge1 tagged=bridge1,bonding1 vlan-ids=1
add bridge=bridge1 tagged=bridge1,bonding1 vlan-ids=50
/interface detect-internet
set detect-interface-list=all
/interface list member
add interface=ether1 list=WAN
add interface=ether5 list=LAN
/interface ovpn-server server
set auth=sha1 certificate="VPN Server" cipher=aes256 default-profile=vpn \
enabled=yes require-client-certificate=yes
/ip address
add address=192.168.0.1/24 interface=ether5 network=192.168.0.0
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.100.1/24 interface=ether4 network=192.168.100.0
add address=xx.xx.xx.xxx/30 interface=ether1 network=78.94.50.180
add address=192.168.30.1/24 interface=vlan30 network=192.168.30.0
add address=192.168.50.1/24 interface=vlan50 network=192.168.50.0
/ip dhcp-server lease
add address=192.168.0.136 allow-dual-stack-queue=no disabled=yes mac-address=\
00:02:C9:4E:89:26 server=server1
add address=192.168.0.113 allow-dual-stack-queue=no disabled=yes mac-address=\
F2:E7:52:EB:6E:9B server=server1
add address=192.168.0.26 client-id=1:0:26:ab:6c:6:27 disabled=yes \
mac-address=00:26:AB:6C:06:27 server=server1
add address=192.168.0.33 client-id=1:0:2:c9:51:77:dc disabled=yes \
mac-address=00:02:C9:51:77:DC server=server1
add address=192.168.50.100 client-id=1:2c:f0:5d:3b:db:d3 disabled=yes \
mac-address=2C:F0:5D:3B:DB:D3 server=WLAN
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 domain=home.lab gateway=\
192.168.0.1 netmask=24
add address=192.168.10.0/24 dns-server=192.168.10.13 domain=service.lab \
gateway=192.168.10.1
add address=192.168.20.0/24 dns-server=192.168.0.1 domain=private.lab \
gateway=192.168.20.1 netmask=24
add address=192.168.30.0/24 dns-server=192.168.30.1 gateway=192.168.30.1
add address=192.168.50.0/24 dns-server=192.168.0.1 domain=private.lab \
gateway=192.168.50.1
add address=192.168.100.0/24 dns-server=192.168.100.1 gateway=192.168.100.1 \
netmask=24
/ip dns
set allow-remote-requests=yes servers=192.168.0.3,192.168.10.13
/ip dns static
add address=192.168.100.110 name=mydomain1.de
add address=192.168.100.110 name=mydomain2.de
add address=192.168.100.110 name=mydomain3.de
add address=192.168.0.131 name=pve.home.lab
add address=192.168.0.2 name=r620.home.lab
add address=192.168.0.113 name=nanopineo.home.lab
add address=192.168.0.128 name=grafana.home.lab
add address=192.168.0.136 name=fileserver.home.lab
add address=192.168.0.10 name=pve2.home.lab
add address=192.168.10.18 name=bookstack.service.lab
add address=192.168.10.123 name=Guacamole.service.lab
add address=192.168.10.101 comment=#DHCP name=Heimdall.service.lab ttl=10m
add address=192.168.10.122 disabled=yes name=avideo.service.lab
add address=192.168.10.123 name=avideo1.service.lab
add address=192.168.0.21 comment=#DHCP name=GUI.home.lab ttl=2h
add address=192.168.0.22 comment=#DHCP name=GUI.home.lab ttl=2h
add address=192.168.0.28 comment=#DHCP name=T530.home.lab ttl=2h
add address=192.168.0.27 comment=#DHCP name=Ryzen-Workstation.home.lab ttl=2h
add address=192.168.10.6 comment=#DHCP name=kubuntu.service.lab ttl=10m
add action=accept chain=forward connection-nat-state=dstnat
add action=drop chain=input connection-state=invalid
add action=accept chain=input comment="Allow Established connections" \
connection-state=established,related
add action=accept chain=input comment="Allow ICMP" protocol=icmp
add action=accept chain=input comment="accept OpenVPN" dst-port=1192 log=yes \
protocol=tcp
add action=accept chain=forward dst-port=51820 protocol=udp
add action=accept chain=forward dst-port=51821 protocol=udp
add action=accept chain=input comment=" accept OVPN->LAN" disabled=yes \
dst-address=192.168.0.0/24 src-address=192.168.124.0/24
add action=drop chain=forward comment="drop invalid connections" \
connection-state=invalid protocol=tcp
add action=accept chain=forward comment=\
"allow already established connections" connection-state=established
add action=reject chain=input dst-port=22 in-interface-list=WAN log=yes \
protocol=tcp reject-with=tcp-reset
add action=drop chain=forward dst-port=22 in-interface-list=WAN log=yes \
protocol=tcp
add action=accept chain=forward comment="allow related connections" \
connection-state=related
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.110 dst-port=443,80 protocol=tcp src-address=192.168.0.30
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.128 dst-port=8086 protocol=tcp src-address=192.168.0.131
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.110 dst-port=443,80 protocol=tcp src-address=192.168.0.19
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.110 dst-port=443,80 protocol=tcp src-address=192.168.0.217
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.156 dst-port=445 protocol=tcp src-address=192.168.0.127
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.0.127 dst-port=445 protocol=tcp src-address=192.168.100.156
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" disabled=yes \
dst-address=192.168.100.138 dst-port=3479 protocol=tcp src-address=\
192.168.100.211
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" disabled=yes \
dst-address=192.168.100.138 dst-port=3479 protocol=udp src-address=\
192.168.100.211
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.110 dst-port=443,80 protocol=tcp src-address=192.168.0.15
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.100.110 dst-port=443,80 protocol=tcp src-address=192.168.0.14
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" dst-address=\
192.168.50.100 protocol=tcp src-address=192.168.100.110 src-port=443,80
add action=accept chain=forward comment=\
"Allow traffic between Workstation and Webserver" disabled=yes \
dst-address=192.168.0.12 protocol=tcp src-address=192.168.100.110 \
src-port=443,80
add action=accept chain=forward comment="allow traffic between these subnets" \
dst-address=192.168.10.0/24 src-address=192.168.0.0/24
add action=accept chain=forward comment="allow traffic between these subnets" \
dst-address=192.168.20.0/24 src-address=192.168.0.0/24
add action=accept chain=forward comment="Allow traffic between these subnets" \
dst-address=192.168.30.0/24 src-address=192.168.0.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.50.0/24 src-address=192.168.0.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.100.0/24 src-address=192.168.0.0/24
add action=accept chain=forward comment="Allow traffic between these subnets" \
dst-address=192.168.0.0/24 src-address=192.168.10.0/24
add action=accept chain=forward comment="Allow traffic between these subnets" \
dst-address=192.168.20.0/24 src-address=192.168.10.0/24
add action=accept chain=forward comment="Allow traffic between these subnets" \
dst-address=192.168.50.0/24 src-address=192.168.10.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.100.0/24 src-address=192.168.10.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
connection-state=established,related dst-address=192.168.0.0/24 \
src-address=192.168.20.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
connection-state=established,related dst-address=192.168.10.0/24 \
src-address=192.168.20.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
connection-state=established,related dst-address=192.168.50.0/24 \
src-address=192.168.20.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.100.0/24 src-address=192.168.20.0/24
add action=accept chain=forward comment="Allow traffic between these subnets" \
dst-address=192.168.0.0/24 src-address=192.168.30.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.50.0/24 src-address=192.168.30.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
connection-state=established,related dst-address=192.168.0.0/24 \
src-address=192.168.50.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
connection-state=established,related dst-address=192.168.10.0/24 \
src-address=192.168.50.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
connection-state=established,related dst-address=192.168.20.0/24 \
src-address=192.168.50.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.0.0/24 src-address=10.9.0.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.0.0/24 src-address=192.168.100.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.20.0/24 src-address=192.168.100.0/24
add action=drop chain=forward comment="Block traffic between these subnets" \
dst-address=192.168.10.0/24 src-address=192.168.100.0/24
add action=accept chain=forward comment="Block traffic between these subnets" \
in-interface=vlan50 out-interface=bridge1
add action=accept chain=forward comment=Drucker dst-address=192.168.0.26 \
in-interface=vlan50 out-interface=bridge1 src-address=192.168.50.0/24
add action=accept chain=forward comment=Drucker dst-address=192.168.50.0/24 \
in-interface=bridge1 out-interface=vlan50 src-address=192.168.0.26
add action=drop chain=input comment="drop ssh from wan" connection-state=\
related in-interface-list=WAN log=yes
add action=drop chain=input comment="drop winbox from wan" dst-port=8291 \
in-interface-list=WAN log=yes protocol=tcp
add action=accept chain=input comment="drop winbox from wan" dst-port=8291 \
in-interface-list=!WAN log=yes protocol=tcp
add action=drop chain=forward comment="Block Fressebuch" layer7-protocol=\
"Block Site" src-address=192.168.0.0/24
add action=accept chain=forward disabled=yes in-interface=ether4 \
src-address-list=192.168.100.0/24
add action=accept chain=input dst-port=4443 protocol=tcp
add action=accept chain=input dst-port=88 protocol=tcp
add action=drop chain=forward src-address=0.0.0.0/8
add action=drop chain=forward dst-address=0.0.0.0/8
add action=drop chain=forward src-address=127.0.0.0/8
add action=drop chain=forward dst-address=127.0.0.0/8
add action=drop chain=forward src-address=224.0.0.0/3
add action=drop chain=forward dst-address=224.0.0.0/3
add action=jump chain=forward jump-target=tcp protocol=tcp
add action=jump chain=forward jump-target=udp protocol=udp
add action=jump chain=forward jump-target=icmp protocol=icmp
add action=accept chain=input dst-port=161 in-interface=bridge1 protocol=udp
add action=accept chain=input dst-port=53 in-interface-list=!WAN protocol=tcp
add action=accept chain=input dst-port=53 in-interface-list=!WAN protocol=udp
add action=drop chain=forward connection-nat-state=!dstnat in-interface-list=\
WAN
add action=drop chain=input dst-port=53 in-interface-list=WAN protocol=tcp
add action=drop chain=input dst-port=53 in-interface-list=WAN protocol=udp
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
protocol=udp
add action=accept chain=forward comment="allow IPsec NAT" dst-port=4500 \
protocol=udp
add action=accept chain=input comment="allow IKE (Wlan Telefonie)" \
connection-type=sip dst-port=500 log=yes protocol=udp
add action=accept chain=forward comment="allow IKE (Wlan Telefonie)" \
dst-port=500 protocol=udp
add action=drop chain=input comment="Block everything else"
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
add action=accept chain=srcnat dst-address-type=local
add action=dst-nat chain=dstnat comment="HTTPS an reverse proxy" dst-address=\
xx.xx.xx.xxx dst-port=80,443 protocol=tcp to-addresses=192.168.100.110
add action=dst-nat chain=dstnat dst-address=xx.xx.xx.xxx dst-port=8444 \
in-interface=ether1 protocol=tcp to-addresses=192.168.100.110 to-ports=\
443
add action=dst-nat chain=dstnat disabled=yes dst-address=xx.xx.xx.xxx \
dst-port=50000 in-interface=ether1 protocol=tcp to-addresses=\
192.168.100.52 to-ports=50000
add action=dst-nat chain=dstnat dst-address=xx.xx.xx.xxx dst-port=1194 \
in-interface=ether1 log=yes protocol=udp to-addresses=192.168.0.113 \
to-ports=1194
add action=dst-nat chain=dstnat dst-address=xx.xx.xx.xxx dst-port=1195 \
in-interface=ether1 protocol=udp to-addresses=192.168.0.250 to-ports=1195
add action=dst-nat chain=dstnat dst-address=xx.xx.xx.xxx dst-port=1197 \
in-interface=ether1 log=yes protocol=udp to-addresses=192.168.0.9 \
to-ports=1197
add action=dst-nat chain=dstnat comment="192.168.0.117: Plex Media Server" \
disabled=yes dst-address=xx.xx.xx.xxx dst-port=26070 in-interface=ether1 \
log=yes protocol=tcp to-addresses=192.168.0.136 to-ports=32400
add action=dst-nat chain=dstnat comment="TURN Server Nextcloud mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=3478 log=yes protocol=tcp to-addresses=\
192.168.100.156 to-ports=3478
add action=dst-nat chain=dstnat comment="TURN Server Nextcloud mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=3479 log=yes protocol=tcp to-addresses=\
192.168.100.156 to-ports=3479
add action=dst-nat chain=dstnat comment="TURN Server Nextcloud mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=3478 protocol=udp to-addresses=\
192.168.100.156 to-ports=3478
add action=dst-nat chain=dstnat comment="TURN Server Nextcloud mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=3479 log=yes protocol=udp to-addresses=\
192.168.100.156 to-ports=3479
add action=dst-nat chain=dstnat comment="TURN Server cloud.mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=5349 log=yes protocol=tcp to-addresses=\
192.168.100.138 to-ports=5349
add action=dst-nat chain=dstnat comment="TURN Server cloud.mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=5350 log=yes protocol=tcp to-addresses=\
192.168.100.138 to-ports=5350
add action=dst-nat chain=dstnat comment="TURN Server cloud.mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=5349 log=yes protocol=udp to-addresses=\
192.168.100.138 to-ports=5349
add action=dst-nat chain=dstnat comment="TURN Server cloud.mydomain1" \
dst-address=xx.xx.xx.xxx dst-port=5350 in-interface=ether1 log=yes \
protocol=udp to-addresses=192.168.100.138 to-ports=5350
add action=dst-nat chain=dstnat disabled=yes dst-address=192.168.0.11 \
dst-port=32400 in-interface=ether1 protocol=tcp to-addresses=\
192.168.0.117 to-ports=26065
add action=dst-nat chain=dstnat dst-port=51820 in-interface=ether1 protocol=\
udp to-addresses=192.168.0.217 to-ports=51820
add action=dst-nat chain=dstnat dst-address=xx.xx.xx.xxx dst-port=51821 \
in-interface=ether1 protocol=udp to-addresses=192.168.0.124 to-ports=\
51821
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
/ip ipsec policy
set 0 disabled=yes
/ip route
add distance=1 gateway=xx.xx.xx.xxx
/ip service
set telnet address=192.168.0.0/24 disabled=yes
set ftp address=192.168.0.0/24 disabled=yes
set www address=192.168.0.0/24 port=88
set ssh address=192.168.0.0/24 disabled=yes
set www-ssl address=192.168.0.0/24 disabled=no port=4443
set api address=192.168.0.0/24 disabled=yes
set winbox address=192.168.0.0/24
set api-ssl address=192.168.0.0/24 disabled=yes
/ip ssh
set allow-none-crypto=yes forwarding-enabled=remote
/ip upnp
set allow-disable-external-interface=yes
/ip upnp interfaces
add type=internal
add interface=ether1 type=external
/ppp secret
add name=AWI profile=vpn service=ovpn
/snmp
set enabled=yes trap-generators="" trap-version=2
/system clock
set time-zone-name=Europe/Berlin
/tool bandwidth-server
set enabled=no
/tool graphing interface
add interface=ether1
add interface=ether5
add interface="ether2(WLAN)"
add interface=ether3
add interface=ether4
add interface=vlan20
add interface=vlan10
/tool mac-server ping
set enabled=no
Eth1 is connected to modem
Eth2 is connected to CSS
Eth3 is connected to CSS
Eth4 is directly connected to a NIC for DMZ
Eth5 is connected to CSS
Eth3 and Eth5 are linked together als a bond