Wireguard doesn't work with a bridge-lan is a ridiculous statement that means nothing!
Wireguard is a peer to peer layer3 construct.
If you want to connect subnets at layer 2 then
a. use zerotier
b. eiop over wg
c. vxlan over wg. etc.
I will connect Two routers, with bridge-LANS using WG.
EASY PEASY.[/color]
Lets say Router one has a single subnet 192.168.1.0/24 attached to a bridge.
Lets say Router two has a single subnet 192.168.2.0/24 attached to a bridge.
Each bridge feeds ports 2,3,4,5
The user requirements is that users from each subnet should be able to reach users in the other subnet.
R1 acts as server for handshake.
/allowed-addresses=10.10.10.2/32,192.168.2.0/24 ... Peer1=R2
/allowed-addresses=10.10.10.3/32 ....Peer2 { admin on remote connection }
R2 acts as client for handshake
/allowed-addresses=10.10.10.0/24,192.168.1.0/24 persistent-keep-alive=30s ...Single Peer=R1
R1 fw rules
add chain=input action=accept dst-port=wireguardlisteningport protocol=udp
add chain=input action=accept in-interface=wg1 src-address=10.10.10.3 { admin wireguard remote config access }
add chain=forward action=accept in-interface=wg1 out-interface=bridge1
add chain=forward action=accept in-interface=bridge1 out-interface=wg1
add chain=forward action=accept in-interface=wg1 out-interface=wg1 { allow admin to relay to R2 }
R1 Routes
/ip route
add dst-address=192.168.2.0/24 gwy=wg1 table=main
R2 fw rules
add chain=input action=accept in-interface=wg2 src-address=10.10.10.3 { allow remote admin to config R2 }
add chain=forward action=accept in-interface=wg2 out-interface=bridge2
add chain=forward action=accept in-interface=bridge2 out-interface=wg2
R2 Routes
/ip route
add dst-address=192.168.1.0/24 gwy=wg2 table=main
DONE" Connected two bridge-lans via wireguards, so please stop smoking dope and then posting.
The alternative comment perhaps more fruitful IS
State the user requirements clearly and accurately.
If you want some ideas on using Wireguard to attempt to join subnets at a Layer 2 level --->
viewtopic.php?t=194646