@mkx, i ll try to explain and i hope you can help
What i find difficulty to understand is this:
If tagged traffic comes from lets say switch 1:
SW1:
/interface vlan
add interface=bridge name=vlan1 vlan-id=201
...
/ip address
add address=192.168.201.4/24 interface=vlan1 network=192.168.201.0
...
/interface bridge vlan
add bridge=bridge tagged=ether1,bridge vlan-ids=201
The traffic coming from ether1 on SW1 is tagged on egress with VID 201...
On Switch2 VID 201 is allowed on egress through ether 5
SW2:
/ip address
add address=192.168.201.1/24 interface=bridge1 network=192.168.201.0
...
/interface bridge vlan
add bridge=bridge1 tagged=ether5 vlan-ids=201
...
/interface bridge
add name=bridge1 pvid=201 vlan-filtering=yes
...
add bridge=bridge1 frame-types=admit-only-vlan-tagged ingress-filtering=yes interface=ether5
From SW1 i can successfully ping 192.168.201.1 SW2 only if PVID on the Bridge itself on SW2 is set to 201...
-1. So since the traffic comes Tagged from SW1 and goes to SW2, SW2 allows VID to egress,
so why if the PVID on the Bridge is different than 201 on SW2, SW1 can not communicate with SW2 ?
-2. Also i noticed that although
ether5 is set to accept only tagged from SW1, and that works fine,
if i do the same on the Bridge, to accept only tagged, communication is then lost... Why ?
-3.
However, if i repeat the same, but this time on SW2
Interface VLAN is added on the Bridge, IP address to the VLAN interface, Tagged Ports the Bridge and ether 5 PVID value on the Bridge makes no different
and when setting the Bridge to accept Tagged traffic only it works just fine ...
That is that i do not understand since the beginning of the post,
why the PVID on the bridge affects tagged traffic,
why the Bridge behaves differently when only tagged traffic must be accepted and
why using VLAN interfaces changes the whole behavior in comparison with 1,2...