I have to start of with saying I'm not good or adept at networking, I never really had any issues with my Mikrotik as a switch.
Since a few months I switched to 10G internet from NTT CROSS (Japan), at first this was fine, but the router they provided is junk.
I have many disconnects at random times, opening ports doesn't work at all, and the UI and options are very limited.
Now I wanted to switch the router functionality to the Mikrotik (CRS309-1G-8S+) and do away with the NTT one.
I've tried many of the guides online that do something similar for other providers, but none of the configs seem to work for me.
This was one of the most promising guide: https://www.rb-ug.jp/blog/1282.html
But according to my ISP the config should be delivered automatically.
This is basically what that page specifies to do (i changed some values to hide them)
Code: Select all
/ipv6 dhcp-client
add add-default-route=yes interface=sfp-sfpplus1 pool-name=NTT request=prefix
/ipv6 address
add address=2405:6584:7c80:305::/56 comment="default gateway ipv6" from-pool=NTT interface=sfp-sfpplus1
/interface ipipv6
add clamp-tcp-mss=yes comment=v6_plus local-address=::/56 mtu=1460 name=ipipv6-v6plus remote-address=2405:6584:7c80:300:fab7:97ff:fe7c:1ed4
/ip address
add address="it says to add provider provided ip, but I have none" interface=ipipv6-v6plus
/ipv6 address
add address=::1 comment="default gateway ipv6" from-pool=NTT interface=bridge1
/ip firewall nat
add action=masquerade chain=srcnat comment="NAT ipipv6" out-interface=ipipv6-tunnel1
/ip firewall mangle
add action=change-mss chain=forward comment="Clamp MSS to PMTU" new-mss=clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=syn
/ipv6 firewall mangle
add action=change-mss chain=forward comment="Clamp MSS to PMTU" new-mss=clamp-to-pmtu passthrough=yes protocol=tcp tcp-flags=syn
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.99
/ip route
add check-gateway=ping distance=1 gateway=dslite
/ipv6 route
add dst-address=::/0 gateway=sfp-sfpplus1 check-gateway=ping type=unicast distance=1 (type unicast doesnt work for me)
/ip dns
set allow-remote-requests=yes cache-size=50000KiB max-concurrent-queries=200 max-concurrent-tcp-sessions=40 servers=208.67.222.222,208.67.220.220,2001:a7ff:5f01::a,2001:a7ff:5f01:1::a