* Side #1 is called "lacinet", it has address 192.168.14.254/24 on BASE (management) vlan.
* Side #2 is called "magnet", it has 192.168.19.254/24 main address on BASE (management) vlan.
* There are also other networks with different vlans on both sides (10.14.VLAN-SIDE1.X and 10.19.VLAN-SIDE2.Y )
* These routers are connected via ipsec/ike2 tunnel over the internet.
On side1, I have these policies:
/ip ipsec policy
set 0 comment="For l2tp-server"
add dst-address=192.168.19.0/24 group=group-magzatom proposal=proposal-s2s-ros src-address=192.168.14.0/24 template=yes
add dst-address=10.19.0.0/16 group=group-magzatom proposal=proposal-s2s-ros src-address=192.168.14.0/24 template=yes
/ip ipsec policy
set 0 comment="For l2tp-server" dst-address=0.0.0.0/0 src-address=0.0.0.0/0
add dst-address=192.168.14.0/24 peer=not_telling.com proposal=proposal-s2s-ros src-address=192.168.19.0/24 tunnel=yes
add dst-address=192.168.14.0/24 peer=not_telling.com proposal=proposal-s2s-ros src-address=10.19.0.0/16 tunnel=yes
[gandalf@r01.magnet] /ip ipsec policy> print
Flags: T - template, B - backup, X - disabled, D - dynamic, I - invalid, A - active, * - default
# PEER TUNNEL SRC-ADDRESS DST-ADDRESS PROTOCOL ACTION LEVEL PH2-COUNT
0 T * ;;; For l2tp-server
0.0.0.0/0 0.0.0.0/0 all
1 A xyzq.abcd.co yes 192.168.19.0/24 192.168.14.0/24 all encrypt require 59
2 A xyzq.abcd.co yes 10.19.0.0/16 192.168.14.0/24 all encrypt require 1
/ip dns static
add forward-to=192.168.19.254 regexp=".*\\.magnet" type=FWD
add comment=magzatom-base forward-to=192.168.19.254 regexp=".*\\.19\\.168\\.192.\\in-addr\\.arpa" type=FWD
add comment=magzatom-vlan forward-to=192.168.19.254 regexp=".*\\.19\\.10.\\in-addr\\.arpa" type=FWD
/ip dns static
add address=192.168.19.254 name=r01.magnet
add address=192.168.19.253 name=r02.magnet
add address=192.168.19.252 name=r03.magnet
add address=10.19.30.10 name=nvr.magnet
add address=10.19.10.101 comment=#DHCP name=nas.magnet. ttl=10m
All right, so I connect a computer on side1 to the network, with DHCP. Let's say that computer1 has address 192.168.14.106
Then I do this
─$ ping 192.168.19.254 130 ↵
PING 192.168.19.254 (192.168.19.254) 56(84) bytes of data.
64 bytes from 192.168.19.254: icmp_seq=1 ttl=63 time=15.7 ms
But if try to ping from router1, then this is what happens:
[gandalf@router.lacinet] > /ping 192.168.19.254
SEQ HOST SIZE TTL TIME STATUS
0 192.168.19.254 timeout
sent=1 received=0 packet-loss=100%
This problem also shows itself with DNS requests. This happens when I want to get the address of a remote machine, specifying the DNS server by hand:
$ host nas.magnet 192.168.19.254
Using domain server:
Name: 192.168.19.254
Address: 192.168.19.254#53
Aliases:
nas.magnet has address 10.19.10.101
$ host nas.magnet
;; connection timed out; no servers could be reached
This is my input chain on side2:
/ip firewall filter> print chain=input
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; Allow UDP 500,4500,1701 for IKE, IPSEC/ESP and L2TP
chain=input action=accept protocol=udp port=1701,500,4500
1 ;;; Allow IPSEC/ESP
chain=input action=accept protocol=ipsec-esp
2 ;;; Accept established,related,untracked
chain=input action=accept connection-state=established,related,untracked
3 ;;; Drop invalid
chain=input action=drop connection-state=invalid
4 ;;; Accept ICMP
chain=input action=accept protocol=icmp
5 ;;; CAPsMAN and CAP
chain=input action=accept src-address-type=local dst-address-type=local
6 ;;; Input from BASE mgmt
chain=input action=accept in-interface-list=BASE
7 ;;; SSH input, with brute force protection
chain=input action=jump jump-target=input_ssh protocol=tcp dst-port=22
8 ;;; Input from VLAN
chain=input action=jump jump-target=input_from_vlan in-interface-list=VLAN
9 ;;; Input from L2TP client
chain=input action=jump jump-target=input_from_l2tp src-address=10.19.200.0/24
10 ;;; DNS from lacinet udp
chain=input action=accept protocol=udp src-address=192.168.14.0/24 dst-port=53
11 ;;; DNS from lacinet tcp
chain=input action=accept protocol=tcp src-address=192.168.14.0/24 dst-port=53
12 ;;; Drop
chain=input action=drop
I can't find out what the problem is. How is it possible that ping does not work router1 -> router2, but it works computer1 -> router1 -> router2 ? What am I not seeing?
p.s.: can could send the whole router config but it is sooo long. Both sides have 4-5 vlans, many other firewall rules (I think most of them are not relevant, they are moved to different chains), also NAT rules, L2TP servers etc.