I have two bridges configured, one for internal traffic (with ether2, ether3). The other for my eventual hotspot traffic (VLAN40 on ether3). I have added an IP to the vlan40-guestwifi interface, and started a DHCP server listening on the vlan40-guestwifi interface. For now I just want to be able to issue an IP address and let the vlan40-guestwifi guests ping the MT.
Can someone tell me what is wrong with the config below? Anyone connecting to ether3 with VLAN40 tagged traffic is not reaching the MT's DHCP server. (Though traffic reaching ether3 untagged is correctly routing out my WAN as designed).
Code: Select all
# mar/06/2022 16:06:45 by RouterOS 7.1.2
# software id = FD0I-C393
#
# model = 850Gx2
# serial number = 71DC06A73D6A
/interface pptp-client
add allow=mschap1,mschap2 comment="PPTP tunnel to site2" connect-to=secure.mydomain.com disabled=no max-mru=1460 max-mtu=1460 name=pptp-tunnel-to-site2 \
profile="PPTP Tunnel Profile" user=pptp-tunnel-from-site3
/interface bridge
add comment="Bridge for hotspot" name=bridge-hotspot
add admin-mac=6C:3B:6B:74:82:0E arp=proxy-arp auto-mac=no comment="Bridge for internal traffic (exc hotspot vlan)" name=bridge-internal \
protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] comment="External Interface" name=ether1-external speed=100Mbps
set [ find default-name=ether2 ] arp=proxy-arp comment="Internal Interface" name=ether2-internal-slave speed=100Mbps
set [ find default-name=ether3 ] advertise=10M-half,10M-full,100M-half,100M-full comment="Ubiquiti UAP AC PRO access point" name=\
ether3-internal-slave speed=100Mbps
set [ find default-name=ether4 ] comment="ATA on Voice subnet (no vlan)" name=ether4-ata speed=100Mbps
set [ find default-name=ether5 ] bandwidth=unlimited/2M comment="Unused - speed limit to 2MBbps" disabled=yes name=ether5-unused speed=100Mbps
/interface l2tp-client
add allow=mschap1,mschap2 comment="L2TP tunnel to site2" connect-to=secure.mydomain.com disabled=no name=l2tp-tunnel-to-site2 profile=\
"L2TP Tunnel Profile" use-ipsec=yes user=l2tp-tunnel-from-site3
/interface vlan
add arp=proxy-arp comment="Voice traffic to PBX (172.31.233.0/24)" interface=bridge-internal mtu=1516 name=vlan10-Voice vlan-id=10
add arp=proxy-arp comment="Camera traffic from VLAN 20(172.31.231.0/24)" interface=bridge-internal mtu=1516 name=vlan20-cameras vlan-id=20
add arp=proxy-arp comment="Entertainment traffic to VLAN Entertainment (172.31.232.0/24)" interface=bridge-internal mtu=1516 name=\
vlan30-entertainment vlan-id=30
add comment="Guest network VLAN 40" interface=bridge-hotspot name=vlan40-guestwifi vlan-id=40
/interface list
add exclude=dynamic name=discover
add name=mactel
add name=mac-winbox
/interface lte apn
set [ find default=yes ] ip-type=ipv4
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=firewall-k
/interface bridge port
add bridge=bridge-internal frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=ether3-internal-slave
add bridge=bridge-internal ingress-filtering=no interface=ether2-internal-slave
add bridge=bridge-hotspot ingress-filtering=no interface=vlan40-guestwifi
/interface bridge settings
set use-ip-firewall=yes
/interface bridge vlan
add bridge=bridge-hotspot tagged=vlan40-guestwifi vlan-ids=40
add bridge=bridge-internal tagged=ether2-internal-slave vlan-ids=10,30,20
/interface l2tp-server server
set authentication=mschap1,mschap2 max-mru=1460 max-mtu=1460
/interface list member
add interface=ether1-external list=discover
add interface=bridge-internal list=discover
add interface=ether3-internal-slave list=discover
add interface=ether4-ata list=discover
add interface=ether5-unused list=discover
add interface=bridge-internal list=mactel
add interface=ether3-internal-slave list=mactel
add interface=ether4-ata list=mactel
add interface=bridge-internal list=mac-winbox
add interface=ether5-unused list=mactel
add interface=ether3-internal-slave list=mac-winbox
add interface=ether4-ata list=mac-winbox
add interface=ether5-unused list=mac-winbox
/interface ovpn-server server
set cipher=blowfish128,aes128,aes192,aes256 enabled=yes keepalive-timeout=disabled
/interface pptp-server server
set default-profile=default max-mru=1460 max-mtu=1460
[admin@firewall-k] >