another question - stupid maybe:
I see that the device has 3 wireless adapters - wlan1..3
I believe Wlan3 is used for mesh (CAPsMAN only), however the other 2 need to be members of the bridge?
In CAPsMAN I have 2 different interfaces and I cannot validate if these 2 are actually mapping the wlan1 and wlan2
wireless interfaces managed by CAPsMAN should not be added to the bridge manually; CAPsMAN will do that for you when it brings the interface up, including configuring the correct VLAN tags.
you can map the CAPsMAN interface to the AP's interface name based on MAC address. for example, here is a CAPsMAN with some radios:
[admin@cr1.stm] /caps-man/radio> print
Flags: P - PROVISIONED
Columns: RADIO-MAC, INTERFACE, REMOTE-CAP-NAME, REMOTE-CAP-IDENTITY
# RADIO-MAC INTERFACE REMOTE-CAP-NAME REMOTE-CAP-IDENTITY
0 P C4:AD:34:18:B9:68 wr2.stm-1 CAP-C4AD3418B962 wr2.stm
1 P 74:4D:28:8E:70:CC wr1.stm-1 CAP-744D288E70C6 wr1.stm
2 P 74:4D:28:8E:70:CB wr1.stm-2 CAP-744D288E70C6 wr1.stm
3 P C4:AD:34:00:3D:A7 wr3.stm-1 CAP-C4AD34003DA1 wr3.stm
4 P 74:4D:28:8E:7A:8F wr4.stm-1 CAP-744D288E7A89 wr4.stm
if we want to find out what interface is "wr2.stm-1", log into that AP and run:
[admin@wr2.stm] /interface/wireless> :put [get [find where mac-address=C4:AD:34:18:B9:68] name]
wlan-5ghz
(in this case i renamed the wireless interfaces to "wlan-2.4ghz" and "wlan-5ghz", if you didn't do that then it would print "wlan1" or "wlan2".)
as far as mesh goes, i'm not familiar with Audience specifically, but i understand it has three radios: low-gain 2.4GHz, low-gain 5GHz, and high-gain 5GHz. i think i would prefer to configure this so the two low-gain radios are managed by CAPsMAN and used for clients, and the high-gain 5GHz radio is not managed by CAPsMAN, instead used for a WDS mesh to interconnect the APs.
VLAN+WDS mesh configuration is like this. on all APs, configure the high-gain wireless interface (which is
not managed by CAPsMAN) with the same SSID and other settings and set wds-mode=static-mesh:
/interface wireless security-profiles
add authentication-types=wpa2-psk disable-pmkid=yes name=my-mesh wpa2-pre-shared-key=XXX
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce country="united kingdom" mode=ap-bridge security-profile=my-mesh ssid=XXXX wds-mode=static-mesh
now on first AP, add WDS link to second AP (using MAC address of the other AP's WDS interface):
[admin@wr2.stm] > /interface/wireless/wds export
/interface wireless wds
add disabled=no master-interface=wlan-2.4ghz name=wr4-wds wds-address=74:4D:28:8E:7A:8E
on second AP, add WDS link to first AP:
[admin@wr4.stm] > /interface/wireless/wds export
/interface wireless wds
add disabled=no master-interface=wlan-2.4ghz name=wr2-wds wds-address=C4:AD:34:18:B9:67
check WDS link came up, it will log a message ("client connected, wants WDS") and interface should have R flag:
[admin@wr4.stm] > /interface/wireless/wds print
Flags: X - disabled; R - running; D - dynamic
0 R name="wr2-wds" mtu=1500 l2mtu=1600 mac-address=74:4D:28:8E:7A:8E arp=enabled arp-timeout=auto master-interface=wlan-2.4ghz wds-address=C4:AD:34:18:B9:67
on both APs, add WDS interfaces to bridge (with VLAN filtering enabled):
[admin@wr4.stm] > /interface/bridge/port export
/interface bridge port
add bridge=lan frame-types=admit-only-vlan-tagged interface=wr2-wds
on both APs, add WDS interface as .1q tagged port in appropriate VLANs:
[admin@wr4.stm] > /interface/bridge/vlan/export
/interface bridge vlan
add bridge=lan tagged=lan,wr2-wds,wr3-wds,wr5-wds vlan-ids=100
add bridge=lan tagged=lan,wr2-wds,wr3-wds,wr5-wds vlan-ids=101
add bridge=lan tagged=lan,wr2-wds,wr3-wds,wr5-wds vlan-ids=102
now the WDS mesh acts as a .1q trunk between your APs, and tagged packets from the CAPsMAN-managed wireless interfaces will flow over WDS.
if you have 3+ APs meshed, make sure RSTP or MSTP is enabled on the bridge to avoid L2 loops. (edit: and make sure STP priority is correctly set so that the wired AP is chosen as the root bridge, otherwise your traffic flow will be weird.)
this can be a bit awkward to configure the first time. i suggest putting all the APs on your desk to set them up, and only physically install them once everything is working.