Page 1 of 1

announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 4:23 pm
by jardielroque
I would like someone to help me, I really need to do a filter to announce my ipv6 block to the operator, and block the millions of routes received by her.

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 4:58 pm
by rextended
Simply ask the operator to provide you only default route, and nothing more.

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 5:12 pm
by jardielroque
Simply ask the operator to provide you only default route, and nothing more.
AND HOW DO I MAKE HIM SEE MY ROUTES, WHY HE CLAIMS I'M NOT ADVERTISEMENT ANY ROUTE

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 5:24 pm
by StubArea51
I would like someone to help me, I really need to do a filter to announce my ipv6 block to the operator, and block the millions of routes received by her.

Here is an IPv6 filtering example for advertised prefixes from a blog post I wrote:

https://stubarea51.net/2021/08/24/mikro ... g-filters/
/routing filter rule
add chain=dead.beef.101 rule="if (dst==200:dead:beef:101::/64) {accept}"
add chain=dead.beef.102 rule="if (dst==200:dead:beef:102::/64) {accept}"
add chain=dead.beef.agg rule="if (dst in 200:dead:beef::/48) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.101) {set bgp-local-pref 300; accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.102) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.agg && dst-len<128) {set bgp-local-pref 150; accept}"

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 5:34 pm
by rextended
Hardware and RouterOS used is not specified.

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 5:36 pm
by jardielroque
I would like someone to help me, I really need to do a filter to announce my ipv6 block to the operator, and block the millions of routes received by her.

Here is an IPv6 filtering example for advertised prefixes from a blog post I wrote:

https://stubarea51.net/2021/08/24/mikro ... g-filters/
/routing filter rule
add chain=dead.beef.101 rule="if (dst==200:dead:beef:101::/64) {accept}"
add chain=dead.beef.102 rule="if (dst==200:dead:beef:102::/64) {accept}"
add chain=dead.beef.agg rule="if (dst in 200:dead:beef::/48) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.101) {set bgp-local-pref 300; accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.102) {accept}"
add chain=bgp-out-v6 rule="if (chain dead.beef.agg && dst-len<128) {set bgp-local-pref 150; accept}"
SORRY BUT IN THIS VERSION I'M BAD STILL, COULD MODIFY JA RULE FOR MY BLOCK ALREADY. FOLLOW THE BLOCK BELOW,

2804:284c::/32

HOW WOULD THE RULE BE?

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 6:06 pm
by rextended
You still haven't specified which RouterOS you are using.

Re: announce ipv6 routes in bgp

Posted: Fri Jun 10, 2022 8:14 pm
by jardielroque
You still haven't specified which RouterOS you are using.
I'm currently using RouterOS 7.2.1 and I'm thinking of upgrading to the latest one, 7.3.1

Re: announce ipv6 routes in bgp

Posted: Mon Jun 13, 2022 5:21 am
by loloski
make sure you have an active route with type = blackhole for the subnet or prefix you want to announce otherwise it won't work because no synchronize is no longer available on ROS v7
and also connection->filter section output.network = bgp-networks should match and have entry on your ipv6 address list
/ipv6 firewall address-list
add address=2804:284c::/32  list=bgp-networks

/routing filter rule
add chain=bgp-out-v6 rule="if (dst in 2804:284c::/32 && dst-len >= 32 && protocol bgp) { accept }"
just my 0.2$

Re: announce ipv6 routes in bgp

Posted: Wed Apr 19, 2023 10:26 pm
by ameza84
Create loopback interface (ej. bridge with no actual interfaces attached to it ) then set the advertised prefix /address to that interface. Considering you already got the BGP session established and the output prefix correctly set on bgp out filter. I had the same issue and got it solved this way.

Cheers!

Re: announce ipv6 routes in bgp

Posted: Mon Sep 30, 2024 2:57 am
by itrack
Same issue, unfortunately I can't find much documentation about ipv6 bgp on routeros 7+

Re: announce ipv6 routes in bgp

Posted: Mon Sep 30, 2024 1:33 pm
by baragoon
@itrack, describe your problem and show your configuration.