We have a RB20411 and have configured L2tp/IPsec VPN on it. Its been working great when our team members connect from different locations. But if there are some team members at the same location like cafe / co-sharing place (basically behind the same router) then only one of them is able to connect via VPN. The connection for others get refused.
Relevant parts of the script below. Can anyone suggest what should be done to allow multiple users to VPN using the same router over internet? Since its a cafe/cosharing space we do not have access to their networks.
Code: Select all
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=\
aes-256-cbc,aes-192-cbc,aes-128-cbc,3des pfs-group=none
/ip pool
add name=dhcp_pool1 ranges=192.168.2.101-192.168.2.175
add name=VPN_pool ranges=192.168.2.176-192.168.2.254
/ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay disabled=no \
interface=bridge1 name=office
/ppp profile
add bridge=bridge1 change-tcp-mss=yes dns-server=192.168.2.1 local-address=\
192.168.2.1 name=L2TP-IN-Profile remote-address=VPN_pool use-encryption=\
yes use-upnp=yes
/queue type
add kind=pcq name=PCQ pcq-classifier=dst-address pcq-dst-address6-mask=64 \
pcq-rate=384 pcq-src-address6-mask=64
/interface l2tp-server server
set authentication=mschap2 default-profile=L2TP-IN-Profile enabled=yes \
ipsec-secret=XXXXXX use-ipsec=yes