hello,
I'm trying to pass 3 pppoe clients from a switch to a mikrotik router, but only one client connects at a time and not all three at the same time, I leave you the images of my configuration, I don't know if I'm overlooking something.
That is correct...I connect to the mikrotik, in the sfp port of the mikrotik I create three vlans (isp1 id=201, isp2 id=202 , isp3 id=203) I create a pppoe-client for those three vlans
/interface bridge
add name=loopback-ospf
/interface ethernet
set [ find default-name=ether4 ] comment=ADMIN
set [ find default-name=ether5 ] comment=ISP4
set [ find default-name=ether8 ] comment=HOME
set [ find default-name=ether9 ] comment="RED LAN 110"
set [ find default-name=ether10 ] comment=MIRADOR
set [ find default-name=ether11 ] comment=RB1100AHX4
set [ find default-name=ether12 ] comment=SERVER
set [ find default-name=sfp1 ] comment="SWITCH TRUNK UBIQUITI"
set [ find default-name=sfp2 ] comment="SWITCH LINKSYS"
/interface vlan
add interface=sfp1 name=FELIPE vlan-id=110
add interface=sfp2 name=ISP1 vlan-id=201
add interface=sfp2 name=ISP2 vlan-id=202
add interface=sfp2 name=ISP3 vlan-id=203
add interface=sfp1 name=KEPHANI vlan-id=100
add interface=ether10 name="LAN CASA Y EDIFICIOS" vlan-id=32
add interface=ether10 name="LAN JUAREZ" vlan-id=34
add interface=ether10 name="LAN RANCHITO" vlan-id=37
add interface=ether10 name="LAN SANTA TERESA" vlan-id=33
add interface=sfp2 name=OFICINA vlan-id=204
add comment=PTP-CAMBIUM interface=sfp1 name="OSPF AREAS" vlan-id=10
add interface=sfp1 name="OSPF ENCINOS" vlan-id=80
add interface=ether10 name="OSPF ESPERANZA" vlan-id=31
add interface=sfp1 name="OSPF LOMA" vlan-id=70
add interface=sfp1 name="OSPF MISIONES" vlan-id=50
add interface=ether10 name="OSPF MONTEBELLO" vlan-id=35
add interface=sfp1 name="OSPF PIPILA" vlan-id=40
add interface=sfp1 name="OSPF PLANCHON 1" vlan-id=20
add interface=sfp1 name="OSPF PLANCHON 2" vlan-id=21
add interface=sfp1 name="OSPF PLAYA AZUL" vlan-id=60
add interface=sfp1 name=SECTORES vlan-id=90
/interface pppoe-client
add disabled=no interface=ISP1 name=pppoe-out1 password=\
NO USER user=\
NO PASSWORD
/interface list
add name="NAT INTERNET"
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool9 ranges=192.168.40.2-192.168.40.254
add name=dhcp_pool2 ranges=192.168.40.2-192.168.40.254
add name=dhcp_pool3 ranges=192.168.110.2-192.168.110.254
/ip dhcp-server
add address-pool=dhcp_pool2 disabled=no interface=OFICINA name=dhcp1
add address-pool=dhcp_pool3 disabled=no interface=ether9 name=dhcp2
/interface pppoe-client
add disabled=no interface=ether2 name=pppoe-out2 password=\
NOT PASSWORD profile=\
default-encryption user=NOT USER
add disabled=no interface=ether3 name=pppoe-out3 password=NOT PASSWORD profile=\
default-encryption user=NOT USER
add interface=sfp1 name=pppoe-out5 password=\
NOT PASSWORD profile=\
default-encryption user=NOT USER
/queue simple
add max-limit=10M/20M name=EDIFICIOS target=\
192.168.44.20/32,192.168.44.21/32,192.168.44.22/32,192.168.44.23/32
/queue type
add kind=pcq name="intermedio down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=7M pcq-src-address6-mask=64
add kind=pcq name="Intermedio up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name="Basico down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name="Basico up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name="Intermedio down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=7M pcq-src-address6-mask=64
add kind=pcq name="Avanzado down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=10M pcq-src-address6-mask=64
add kind=pcq name="Avanzado up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
/queue tree
add max-limit=400M name=Download parent=global priority=1 queue=default
add limit-at=100M max-limit=400M name="Intermedio down" packet-mark=\
intermedio_pk parent=Download queue="Intermedio down"
add limit-at=100M max-limit=400M name="Avanzado down" packet-mark=avanzado_pk \
parent=Download queue="Avanzado down"
add limit-at=200M max-limit=400M name="Basico down" packet-mark=basico_pk \
parent=Download priority=2 queue="Basico down"
/routing ospf area
add area-id=1.0.1.0 name=area1
add area-id=3.0.3.0 name=area3
add area-id=4.0.4.0 name=area4
add area-id=5.0.5.0 name=area5
add area-id=7.0.7.0 name=area7
add area-id=2.0.2.0 name=area2
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-1 \
redistribute-connected=as-type-1 router-id=11.255.255.1
/interface list member
add interface=pppoe-out1 list="NAT INTERNET"
add interface=pppoe-out2 list="NAT INTERNET"
add interface=pppoe-out3 list="NAT INTERNET"
add interface=ether11 list="NAT INTERNET"
/ip address
add address=10.2.2.33/30 interface="OSPF PLANCHON 1" network=10.2.2.32
add address=192.168.110.1/24 interface=ether9 network=192.168.110.0
add address=10.2.2.85/30 interface="OSPF MISIONES" network=10.2.2.84
add address=10.16.1.1/29 comment="PTP AREAS 1" interface="OSPF AREAS" \
network=10.16.1.0
add address=10.2.2.26/30 interface="OSPF AREAS" network=10.2.2.24
add address=10.16.1.33/29 comment="PTP MIRADOR" interface=ether10 network=\
10.16.1.32
add address=10.2.2.29/30 interface="OSPF ESPERANZA" network=10.2.2.28
add address=192.168.44.1/24 interface="LAN CASA Y EDIFICIOS" network=\
192.168.44.0
add address=192.168.42.1/24 interface="LAN SANTA TERESA" network=192.168.42.0
add address=192.168.46.1/24 interface="LAN JUAREZ" network=192.168.46.0
add address=10.2.2.65/30 interface="OSPF MONTEBELLO" network=10.2.2.64
add address=10.18.1.41/29 comment="PTP PLANCHON 1" interface=\
"OSPF PLANCHON 1" network=10.18.1.40
add address=10.3.1.1/30 interface=sfp1 network=10.3.1.0
add address=10.3.1.5/30 comment="SWITCH MIRADOR" interface=ether10 network=\
10.3.1.4
add address=10.2.2.57/30 interface="OSPF PIPILA" network=10.2.2.56
add address=10.2.2.98/30 interface="OSPF LOMA" network=10.2.2.96
add address=32.1.1.254/24 interface=SECTORES network=32.1.1.0
add address=192.168.40.1/24 interface=OFICINA network=192.168.40.0
add address=10.255.255.1 interface=loopback-ospf network=10.255.255.1
add address=10.16.10.1/30 comment="LAN SERVER" interface=ether12 network=\
10.16.10.0
add address=10.16.2.1/29 comment="PTP PIPILA" interface="OSPF PIPILA" \
network=10.16.2.0
add address=10.2.2.37/30 interface="OSPF ENCINOS" network=10.2.2.36
add address=10.18.1.49/29 comment="PTP ENCINOS" interface="OSPF ENCINOS" \
network=10.18.1.48
add address=10.16.2.9/29 comment="PTP LOMA" interface="OSPF LOMA" network=\
10.16.2.8
add address=10.16.1.57/29 comment="PTP PLAYA AZUL" interface=\
"OSPF PLAYA AZUL" network=10.16.1.56
add address=10.2.2.5/30 interface="OSPF PLAYA AZUL" network=10.2.2.4
add address=10.16.1.105/29 comment="PTP ESPERANZA" interface="OSPF ESPERANZA" \
network=10.16.1.104
add address=10.16.2.17/29 comment="PTP LAN JUAREZ" interface="LAN JUAREZ" \
network=10.16.2.16
add address=10.16.1.65/29 comment="PTP MONTEBELLO" interface=\
"OSPF MONTEBELLO" network=10.16.1.64
add address=192.168.47.1/24 interface="LAN RANCHITO" network=192.168.47.0
add address=10.16.1.113/29 comment="PTP RANCHITO" interface="LAN RANCHITO" \
network=10.16.1.112
add address=172.16.2.2/30 interface=ether11 network=172.16.2.0
add address=10.2.2.53/30 interface="OSPF PLANCHON 2" network=10.2.2.52
add address=10.16.1.121/29 comment="PTP PLANCHON 2" interface=\
"OSPF PLANCHON 2" network=10.16.1.120
add address=10.18.1.57/29 comment="PTP MISIONES" interface="OSPF MISIONES" \
network=10.18.1.56
add address=10.16.2.25/29 comment="PTP SANTA TERESA" interface=\
"LAN SANTA TERESA" network=10.16.2.24
add address=192.168.13.1/24 interface=ether5 network=192.168.13.0
add address=10.10.1.1/29 interface=KEPHANI network=10.10.1.0
add address=10.16.3.1/29 interface=FELIPE network=10.16.3.0
add address=192.168.49.1/24 interface=FELIPE network=192.168.49.0
add address=172.16.4.1/29 interface=sfp2 network=172.16.4.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-server network
add address=192.168.40.0/24 gateway=192.168.40.1
add address=192.168.110.0/24 gateway=192.168.110.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall address-list
/ip firewall filter
/ip firewall mangle
/ip route
add distance=2 gateway=pppoe-out1 routing-mark=to_pppoe-out1
add distance=2 gateway=pppoe-out2 routing-mark=to_pppoe-out2
add distance=2 gateway=pppoe-out3 routing-mark=to_pppoe-out3
add distance=1 gateway=pppoe-out2
add distance=2 gateway=pppoe-out1
add distance=3 gateway=pppoe-out3
add distance=1 dst-address=10.2.2.12/30 gateway=10.2.2.25,10.2.2.42
add distance=1 dst-address=172.16.1.0/28 gateway=172.16.2.1
add distance=1 dst-address=192.168.31.0/24 gateway=10.2.2.25,10.2.2.42
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api address=10.1.1.2/32,192.168.40.0/24
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=pppoe-out5 type=external
add interface=ether4 type=internal
/lcd
set backlight-timeout=never
/routing bfd interface
set [ find default=yes ] disabled=yes
/routing ospf interface
add interface="OSPF AREAS" network-type=point-to-point
add interface="OSPF PLANCHON 1" network-type=point-to-point
add interface="OSPF MISIONES" network-type=point-to-point
add interface="OSPF MONTEBELLO" network-type=nbma
add interface="OSPF ESPERANZA" network-type=point-to-point
add interface="OSPF PLAYA AZUL" network-type=point-to-point
add interface="OSPF LOMA" network-type=nbma
add interface="OSPF ENCINOS" network-type=point-to-point
add interface="OSPF PIPILA" network-type=point-to-point
add interface="OSPF PLANCHON 2" network-type=point-to-point
/routing ospf nbma-neighbor
add address=10.2.2.97
add address=10.2.2.98 priority=1
add address=10.2.2.66
add address=10.2.2.65 priority=1
/routing ospf network
add area=area3 network=10.2.2.32/30
add area=area1 network=10.2.2.24/30
add area=area4 network=10.2.2.84/30
add area=area5 network=10.2.2.64/30
add area=area7 network=10.2.2.28/30
add area=area1 network=10.2.2.4/30
add area=area2 network=10.2.2.96/30
add area=area2 network=10.2.2.36/30
add area=backbone network=10.2.2.56/30
add area=area1 network=10.2.2.40/30
add area=area3 network=10.2.2.52/30
/system clock
/system identity
set name=CCR-CENTRO
/interface vlan
add interface=sfp2 name=ISP1 vlan-id=201
add interface=sfp2 name=ISP2 vlan-id=202
add interface=sfp2 name=ISP3 vlan-id=203
/interface pppoe-client
add disabled=no interface=ISP1 name=pppoe-isp1
add disabled=no interface=ISP2 name=pppoe-isp2
add disabled=no interface=ISP3 name=pppoe-isp3
Switching looks fine.
It should be untagged on the ingress ports from the ISP's, tagged on the egress port to the router.
Are the 3 ISP links using:
1) Same ISP?
2) Same Username?
3) Connecting to the same PPPoE Server somehow like a vISP setup? (Do you get the same service name on each pppoe client?)
Either way, show us a full export of your mikrotik router /export hide-sensitive so we can see a bit more about the setup and if there's a misconfiguration.
/interface bridge
add name=loopback-ospf
/interface ethernet
set [ find default-name=ether4 ] comment=ADMIN
set [ find default-name=ether5 ] comment=ISP4
set [ find default-name=ether8 ] comment=HOME
set [ find default-name=ether9 ] comment="RED LAN 110"
set [ find default-name=ether10 ] comment=MIRADOR
set [ find default-name=ether11 ] comment=RB1100AHX4
set [ find default-name=ether12 ] comment=SERVER
set [ find default-name=sfp1 ] comment="SWITCH TRUNK UBIQUITI"
set [ find default-name=sfp2 ] comment="SWITCH LINKSYS"
/interface vlan
add interface=sfp1 name=FELIPE vlan-id=110
add interface=sfp2 name=ISP1 vlan-id=201
add interface=sfp2 name=ISP2 vlan-id=202
add interface=sfp2 name=ISP3 vlan-id=203
add interface=sfp1 name=KEPHANI vlan-id=100
add interface=ether10 name="LAN CASA Y EDIFICIOS" vlan-id=32
add interface=ether10 name="LAN JUAREZ" vlan-id=34
add interface=ether10 name="LAN RANCHITO" vlan-id=37
add interface=ether10 name="LAN SANTA TERESA" vlan-id=33
add interface=sfp2 name=OFICINA vlan-id=204
add comment=PTP-CAMBIUM interface=sfp1 name="OSPF AREAS" vlan-id=10
add interface=sfp1 name="OSPF ENCINOS" vlan-id=80
add interface=ether10 name="OSPF ESPERANZA" vlan-id=31
add interface=sfp1 name="OSPF LOMA" vlan-id=70
add interface=sfp1 name="OSPF MISIONES" vlan-id=50
add interface=ether10 name="OSPF MONTEBELLO" vlan-id=35
add interface=sfp1 name="OSPF PIPILA" vlan-id=40
add interface=sfp1 name="OSPF PLANCHON 1" vlan-id=20
add interface=sfp1 name="OSPF PLANCHON 2" vlan-id=21
add interface=sfp1 name="OSPF PLAYA AZUL" vlan-id=60
add interface=sfp1 name=SECTORES vlan-id=90
/interface pppoe-client
add disabled=no interface=ISP1 name=pppoe-out1 password=\
NO USER user=\
NO PASSWORD
/interface list
add name="NAT INTERNET"
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool9 ranges=192.168.40.2-192.168.40.254
add name=dhcp_pool2 ranges=192.168.40.2-192.168.40.254
add name=dhcp_pool3 ranges=192.168.110.2-192.168.110.254
/ip dhcp-server
add address-pool=dhcp_pool2 disabled=no interface=OFICINA name=dhcp1
add address-pool=dhcp_pool3 disabled=no interface=ether9 name=dhcp2
/interface pppoe-client
add disabled=no interface=ether2 name=pppoe-out2 password=\
NOT PASSWORD profile=\
default-encryption user=NOT USER
add disabled=no interface=ether3 name=pppoe-out3 password=NOT PASSWORD profile=\
default-encryption user=NOT USER
add interface=sfp1 name=pppoe-out5 password=\
NOT PASSWORD profile=\
default-encryption user=NOT USER
/queue simple
add max-limit=10M/20M name=EDIFICIOS target=\
192.168.44.20/32,192.168.44.21/32,192.168.44.22/32,192.168.44.23/32
/queue type
add kind=pcq name="intermedio down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=7M pcq-src-address6-mask=64
add kind=pcq name="Intermedio up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name="Basico down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name="Basico up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-rate=2M pcq-src-address6-mask=64
add kind=pcq name="Intermedio down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=7M pcq-src-address6-mask=64
add kind=pcq name="Avanzado down" pcq-classifier=dst-address \
pcq-dst-address6-mask=64 pcq-rate=10M pcq-src-address6-mask=64
add kind=pcq name="Avanzado up" pcq-classifier=src-address \
pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
/queue tree
add max-limit=400M name=Download parent=global priority=1 queue=default
add limit-at=100M max-limit=400M name="Intermedio down" packet-mark=\
intermedio_pk parent=Download queue="Intermedio down"
add limit-at=100M max-limit=400M name="Avanzado down" packet-mark=avanzado_pk \
parent=Download queue="Avanzado down"
add limit-at=200M max-limit=400M name="Basico down" packet-mark=basico_pk \
parent=Download priority=2 queue="Basico down"
/routing ospf area
add area-id=1.0.1.0 name=area1
add area-id=3.0.3.0 name=area3
add area-id=4.0.4.0 name=area4
add area-id=5.0.5.0 name=area5
add area-id=7.0.7.0 name=area7
add area-id=2.0.2.0 name=area2
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-1 \
redistribute-connected=as-type-1 router-id=11.255.255.1
/interface list member
add interface=pppoe-out1 list="NAT INTERNET"
add interface=pppoe-out2 list="NAT INTERNET"
add interface=pppoe-out3 list="NAT INTERNET"
add interface=ether11 list="NAT INTERNET"
/ip address
add address=10.2.2.33/30 interface="OSPF PLANCHON 1" network=10.2.2.32
add address=192.168.110.1/24 interface=ether9 network=192.168.110.0
add address=10.2.2.85/30 interface="OSPF MISIONES" network=10.2.2.84
add address=10.16.1.1/29 comment="PTP AREAS 1" interface="OSPF AREAS" \
network=10.16.1.0
add address=10.2.2.26/30 interface="OSPF AREAS" network=10.2.2.24
add address=10.16.1.33/29 comment="PTP MIRADOR" interface=ether10 network=\
10.16.1.32
add address=10.2.2.29/30 interface="OSPF ESPERANZA" network=10.2.2.28
add address=192.168.44.1/24 interface="LAN CASA Y EDIFICIOS" network=\
192.168.44.0
add address=192.168.42.1/24 interface="LAN SANTA TERESA" network=192.168.42.0
add address=192.168.46.1/24 interface="LAN JUAREZ" network=192.168.46.0
add address=10.2.2.65/30 interface="OSPF MONTEBELLO" network=10.2.2.64
add address=10.18.1.41/29 comment="PTP PLANCHON 1" interface=\
"OSPF PLANCHON 1" network=10.18.1.40
add address=10.3.1.1/30 interface=sfp1 network=10.3.1.0
add address=10.3.1.5/30 comment="SWITCH MIRADOR" interface=ether10 network=\
10.3.1.4
add address=10.2.2.57/30 interface="OSPF PIPILA" network=10.2.2.56
add address=10.2.2.98/30 interface="OSPF LOMA" network=10.2.2.96
add address=32.1.1.254/24 interface=SECTORES network=32.1.1.0
add address=192.168.40.1/24 interface=OFICINA network=192.168.40.0
add address=10.255.255.1 interface=loopback-ospf network=10.255.255.1
add address=10.16.10.1/30 comment="LAN SERVER" interface=ether12 network=\
10.16.10.0
add address=10.16.2.1/29 comment="PTP PIPILA" interface="OSPF PIPILA" \
network=10.16.2.0
add address=10.2.2.37/30 interface="OSPF ENCINOS" network=10.2.2.36
add address=10.18.1.49/29 comment="PTP ENCINOS" interface="OSPF ENCINOS" \
network=10.18.1.48
add address=10.16.2.9/29 comment="PTP LOMA" interface="OSPF LOMA" network=\
10.16.2.8
add address=10.16.1.57/29 comment="PTP PLAYA AZUL" interface=\
"OSPF PLAYA AZUL" network=10.16.1.56
add address=10.2.2.5/30 interface="OSPF PLAYA AZUL" network=10.2.2.4
add address=10.16.1.105/29 comment="PTP ESPERANZA" interface="OSPF ESPERANZA" \
network=10.16.1.104
add address=10.16.2.17/29 comment="PTP LAN JUAREZ" interface="LAN JUAREZ" \
network=10.16.2.16
add address=10.16.1.65/29 comment="PTP MONTEBELLO" interface=\
"OSPF MONTEBELLO" network=10.16.1.64
add address=192.168.47.1/24 interface="LAN RANCHITO" network=192.168.47.0
add address=10.16.1.113/29 comment="PTP RANCHITO" interface="LAN RANCHITO" \
network=10.16.1.112
add address=172.16.2.2/30 interface=ether11 network=172.16.2.0
add address=10.2.2.53/30 interface="OSPF PLANCHON 2" network=10.2.2.52
add address=10.16.1.121/29 comment="PTP PLANCHON 2" interface=\
"OSPF PLANCHON 2" network=10.16.1.120
add address=10.18.1.57/29 comment="PTP MISIONES" interface="OSPF MISIONES" \
network=10.18.1.56
add address=10.16.2.25/29 comment="PTP SANTA TERESA" interface=\
"LAN SANTA TERESA" network=10.16.2.24
add address=192.168.13.1/24 interface=ether5 network=192.168.13.0
add address=10.10.1.1/29 interface=KEPHANI network=10.10.1.0
add address=10.16.3.1/29 interface=FELIPE network=10.16.3.0
add address=192.168.49.1/24 interface=FELIPE network=192.168.49.0
add address=172.16.4.1/29 interface=sfp2 network=172.16.4.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-server network
add address=192.168.40.0/24 gateway=192.168.40.1
add address=192.168.110.0/24 gateway=192.168.110.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall address-list
/ip firewall filter
/ip firewall mangle
/ip route
add distance=2 gateway=pppoe-out1 routing-mark=to_pppoe-out1
add distance=2 gateway=pppoe-out2 routing-mark=to_pppoe-out2
add distance=2 gateway=pppoe-out3 routing-mark=to_pppoe-out3
add distance=1 gateway=pppoe-out2
add distance=2 gateway=pppoe-out1
add distance=3 gateway=pppoe-out3
add distance=1 dst-address=10.2.2.12/30 gateway=10.2.2.25,10.2.2.42
add distance=1 dst-address=172.16.1.0/28 gateway=172.16.2.1
add distance=1 dst-address=192.168.31.0/24 gateway=10.2.2.25,10.2.2.42
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api address=10.1.1.2/32,192.168.40.0/24
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=pppoe-out5 type=external
add interface=ether4 type=internal
/lcd
set backlight-timeout=never
/routing bfd interface
set [ find default=yes ] disabled=yes
/routing ospf interface
add interface="OSPF AREAS" network-type=point-to-point
add interface="OSPF PLANCHON 1" network-type=point-to-point
add interface="OSPF MISIONES" network-type=point-to-point
add interface="OSPF MONTEBELLO" network-type=nbma
add interface="OSPF ESPERANZA" network-type=point-to-point
add interface="OSPF PLAYA AZUL" network-type=point-to-point
add interface="OSPF LOMA" network-type=nbma
add interface="OSPF ENCINOS" network-type=point-to-point
add interface="OSPF PIPILA" network-type=point-to-point
add interface="OSPF PLANCHON 2" network-type=point-to-point
/routing ospf nbma-neighbor
add address=10.2.2.97
add address=10.2.2.98 priority=1
add address=10.2.2.66
add address=10.2.2.65 priority=1
/routing ospf network
add area=area3 network=10.2.2.32/30
add area=area1 network=10.2.2.24/30
add area=area4 network=10.2.2.84/30
add area=area5 network=10.2.2.64/30
add area=area7 network=10.2.2.28/30
add area=area1 network=10.2.2.4/30
add area=area2 network=10.2.2.96/30
add area=area2 network=10.2.2.36/30
add area=backbone network=10.2.2.56/30
add area=area1 network=10.2.2.40/30
add area=area3 network=10.2.2.52/30
/system clock
/system identity
set name=CCR-CENTRO
Great, thanks for the solution, the model of my equipment is: CCR1036-12G-4S I'm going to try.It should be possible to use /interface bridge nat to make the ISP see each of your PPPoE clients with a distinct MAC address while using VLANs on the same bridge and therefore with the same actual MAC address. I'd only alias the MAC addresses for two VLANs. And I'd use MAC addresses of other interfaces of the Mikrotik as the aliases, or you may use MAC addresses of some devices you are sure you'll never connect to the switch - like some of your old gear not used any more.
/interface bridge nat
add chain=input in-interface=sfp2 dst-mac-address=08:55:31:0D:65:88/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe-discovery action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=input in-interface=sfp2 dst-mac-address=08:55:31:0D:65:89/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe-discovery action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=input in-interface=sfp2 dst-mac-address=08:55:31:0D:65:88/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-
id=202 vlan-encap=pppoe action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=input in-interface=sfp2 dst-mac-address=08:55:31:0D:65:89/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-
id=203 vlan-encap=pppoe action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe-discovery action=src-nat to-src-mac-address=08:55:31:0D:65:89
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe-discovery action=src-nat to-src-mac-address=08:55:31:0D:65:89
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe action=src-nat to-src-mac-address=08:55:31:0D:65:89
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe action=src-nat to-src-mac-address=08:55:31:0D:65:89
Depending on your CPU architecture, there may be an issue - on some architectures, the vlan-encap value has to be configured as a numeric value with swapped bytes, i.e. 0x6388 instead of pppoe-discovery and 0x6488 instead of pppoe.
/interface bridge nat
add chain=input in-interface=sfp2 dst-mac-address=64:D1:54:CE:F2:31/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe-discovery action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=input in-interface=sfp2 dst-mac-address=64:D1:54:CE:F2:32/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe-discovery action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=input in-interface=sfp2 dst-mac-address=64:D1:54:CE:F2:31/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=input in-interface=sfp2 dst-mac-address=64:D1:54:CE:F2:32/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe action=dst-nat to-dst-mac-address=08:55:31:0D:65:87
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe-discovery action=src-nat to-src-mac-address=64:D1:54:CE:F2:31
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe-discovery action=src-nat to-src-mac-address=64:D1:54:CE:F2:32
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=202 vlan-encap=pppoe action=src-nat to-src-mac-address=64:D1:54:CE:F2:31
add chain=output out-interface=sfp2 src-mac-address=08:55:31:0D:65:87/FF:FF:FF:FF:FF:FF mac-protocol=vlan vlan-id=203 vlan-encap=pppoe action=src-nat to-src-mac-address=64:D1:54:CE:F2:32
Maybe the endianness issue affects the TILE architecture as well. Try replacing pppoe-discovery by 0x6388 and pppoe by 0x6488 in the rules as I've suggested.for some reason it doesn't work, I noticed that there is no packet count in the rules
In the last posted configuration the interface to the switch, and onward to the WAN connections, is not in a bridge. Should be something like
/interface bridge
...
add name=bridge protocol-mode=none
/interface bridge port
add bridge=bridge interface=sfp2
/interface vlan
...
add interface=sfp2bridge name=ISP1 vlan-id=201
add interface=sfp2bridge name=ISP2 vlan-id=202
add interface=sfp2bridge name=ISP3 vlan-id=203
add interface=sfp2bridge name=OFICINA vlan-id=204