LTE1
(1) Allowed IPs is set at 0.0.0.0/0 for wireguard.
Q. Is this because you want to go out the internet on the CHR ??
Think carefully of this entry it says ANY IP address local LAN users want to reach would be allowed into the tunnel (need fw rules and routing to match of course).
It says accept any IP coming out of the tunnel and onto my LTE.
(2) The IP address is good, /24 here as it should be for a MT device.
(3) What is the purpose of these rules
add action=accept chain=input dst-port=13231 in-interface=lte1 protocol=udp
add action=accept chain=input dst-port=13231 in-interface=lte2 protocol=udp
The LTE1 is a client and has NO need for input chain rules from the internet.
The traffic or connection is established on the outbound to the CHR. The CHR needs the input chain rule.
Where you may want an input chain rule is for the admin to lets say configure the LTE1 remotely, lets say from a coffee shop using your iphone.
You wireguard into the CHR, traverse the tunnel and then config the LTE1.
So on the LTE1 you would need an input chain rule something like.
add chain=input action=accept in-interface=wg1 src-address=Wireguard assigned IP { to your iphone }
(4) What is the purpose of this rule................. open ended rules are generally weak to implement.
add action=accept chain=forward connection-state=established,related \
in-interface=wireguard1 TO WHAT is allowed specifically ??
(5) Why do you need to masquerade the traffic going into the tunnel??
add action=masquerade chain=srcnat out-interface=wireguard1
+++++++++++++++++++++++++++
LTE2
(6) Same issue with allowed IPs as LTE1, could be okay, but you need to clarify the intentions......
/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address="chr ip" endpoint-port=\
13231 interface=wireguard1 public-key=\
(7) Not sure why you are using same port for two different VPNs probably not a good idea......
add action=accept chain=input comment="Allow WinBox over VPN" dst-port=8291 \
in-interface=ovpn-ftth protocol=tcp
add action=accept chain=input comment="Allow WinBox over VPN" dst-port=8291 \
in-interface=wireguard1 protocol=tcp
In general I never post an actual VPN port where its not fixed and known, so recommend actually changing it on this device, but use 8291 as a fake entry.

As per the LTE1, also since many people are using the tunnel suggest be more restrictive in your input chain rule.
add action=accept chain=input comment="Allow WinBox over VPN" dst-port=
8291 \
in-interface=wireguard1 protocol=tcp[/i]
src-address-list=Authorized
where firewall address list is something like
add address=iphonewireguard IP address list=authorized
add address=LTE1 admin IP address list=authorized
etc........
(8) What is the purpose of this rule on the LTE2, it is not clear to me that users are coming to the LTE2 to go out its internet for example.????
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface=wireguard1
NEXT POST WILL LOOK AT LTE1,2 routing