I'm trying to give priority to gaming and I want to make sure that my config is correct.
I've seen some people put the game server IP address in dst-address in both mark connection rules, and others in src-address in one rule and in dst-address in the second and I don't know which one is correct.
Code: Select all
/ip firewall mangle
add action=mark-connection chain=prerouting comment="Gaming mark connection" \
new-connection-mark=Gaming_conn passthrough=yes src-address=49.51.0.0/16
add action=mark-connection chain=prerouting dst-address=49.51.0.0/16 \
new-connection-mark=Gaming_conn passthrough=yes
add action=mark-packet chain=prerouting comment="Gaming mark packet" \
connection-mark=Gaming_conn new-packet-mark=Gaming_packets passthrough=no
/queue simple
add comment="Main Parent" max-limit=200M/200M name="Global" queue=\
sfq-default/sfq-default target=10.20.0.0/24,10.100.0.0/24 \
total-queue=sfq-default
add limit-at=10M/10M max-limit=20M/20M name=Gaming packet-marks=Gaming_packets \
parent="Global" priority=1/1 queue=\
pcq-upload-default/pcq-download-default target=\
10.20.0.0/24,10.100.0.0/24
add max-limit=200M/200M name=Clients parent="Global" target=\
10.20.0.0/24,10.100.0.0/24