What does HW-Offload mean when two switch chips on CCR2004?
Posted: Fri Oct 14, 2022 12:13 am
I have this config on my CCR2004-16G-2S+:
Mikrotik docs say "Currently, CRS3xx, CRS5xx series switches, CCR2116, CCR2216 routers and RTL8367, 88E6393X, 88E6191X and MT7621 switch chips (since RouterOS v7) are capable of using bridge VLAN filtering and hardware offloading at the same time"
The CCR2004 has two Marvell-88E6191X:
So with the above configuration, I see:
I am correct that despite it saying there is "H - HW-OFFLOAD" on all ports, it will not be using HW offloading when VLAN 60 traffic is going from ether1 (tagged) to ether12 (untagged) because that is spanning switch chips?
So the H flag only means you have the potentially for HW offloading within your same switch chip?
Code: Select all
# jan/02/1970 12:51:37 by RouterOS 7.5
# software id = XXXXXXXXXX
#
# model = CCR2004-16G-2S+
# serial number = XXXXXXXXXX
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface bridge port
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=ether1
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether2 pvid=20
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether12 pvid=60
/interface bridge vlan
add bridge=bridge1 tagged=ether1 vlan-ids=20
add bridge=bridge1 tagged=ether1 vlan-ids=60
/system identity
set name=test-gw1
Mikrotik docs say "Currently, CRS3xx, CRS5xx series switches, CCR2116, CCR2216 routers and RTL8367, 88E6393X, 88E6191X and MT7621 switch chips (since RouterOS v7) are capable of using bridge VLAN filtering and hardware offloading at the same time"
The CCR2004 has two Marvell-88E6191X:
Code: Select all
[admin@test-gw1] /interface/ethernet/switch> print
Columns: NAME, TYPE, L3-HW-OFFLOADING
# NAME TYPE L3-HW-OFFLOADING
0 switch1 Marvell-88E6191X no
1 switch2 Marvell-88E6191X no
So with the above configuration, I see:
Code: Select all
[admin@test-gw1] /interface/bridge/port> print
Flags: I - INACTIVE; H - HW-OFFLOAD
Columns: INTERFACE, BRIDGE, HW, PVID, PRIORITY, PATH-COST, INTERNAL-PATH-COST, HORIZON
# INTERFACE BRIDGE HW PVID PRIORITY PATH-COST INTERNAL-PATH-COST HORIZON
0 IH ether1 bridge1 yes 1 0x80 10 10 none
1 IH ether2 bridge1 yes 20 0x80 10 10 none
2 IH ether12 bridge1 yes 60 0x80 10 10 none
[admin@test-gw1] /interface/bridge/port>
I am correct that despite it saying there is "H - HW-OFFLOAD" on all ports, it will not be using HW offloading when VLAN 60 traffic is going from ether1 (tagged) to ether12 (untagged) because that is spanning switch chips?
So the H flag only means you have the potentially for HW offloading within your same switch chip?