Page 1 of 1

Unbound container setup

Posted: Sat Nov 05, 2022 6:53 pm
by jb7
I have followed the instructions as per the wiki on setting up Pi and it works great!

Now I would like to setup Unbound as a container for a DNS solution but can't find any information on how to do this on the Mikrotik.

Any help would be appreciated!

Re: Unbound container setup

Posted: Fri Nov 18, 2022 6:24 pm
by elico
I have followed the instructions as per the wiki on setting up Pi and it works great!

Now I would like to setup Unbound as a container for a DNS solution but can't find any information on how to do this on the Mikrotik.

Any help would be appreciated!
Just a recursive caching DNS server?

A simple unbound container can be found at:
https://github.com/elico/unbound-container

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.

Re: Unbound container setup

Posted: Fri Nov 18, 2022 6:47 pm
by mozerd
You should install Pi and unbound into one container … a much better approach.

https://github.com/chriscrowe/docker-pi ... -container

Re: Unbound container setup

Posted: Thu Nov 24, 2022 1:24 pm
by sunakashi
You should install Pi and unbound into one container … a much better approach.

https://github.com/chriscrowe/docker-pi ... -container
Please, could you write how to deploy this container on RouterOS? I would like to have exactly this directly on my hAP ac3. I'm running just pi-hole for now. Thanks.

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
Is it right IP addresses if I already have docker with pi-hole on 172.17.0.0 network?

Re: Unbound container setup

Posted: Sun Dec 04, 2022 10:42 pm
by elico
Then change the network to .17 compared to .20 and it should work.
I am using the 172.20 since I have local machines with docker which the default network of choice is 172.17 so... I am using another network on the MT device so these containers can reach the DNS or another service.
You should install Pi and unbound into one container … a much better approach.

https://github.com/chriscrowe/docker-pi ... -container
Please, could you write how to deploy this container on RouterOS? I would like to have exactly this directly on my hAP ac3. I'm running just pi-hole for now. Thanks.

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
Is it right IP addresses if I already have docker with pi-hole on 172.17.0.0 network?

Re: Unbound container setup

Posted: Fri Jan 06, 2023 9:05 am
by jimint
I have followed the instructions as per the wiki on setting up Pi and it works great!

Now I would like to setup Unbound as a container for a DNS solution but can't find any information on how to do this on the Mikrotik.

Any help would be appreciated!
Just a recursive caching DNS server?

A simple unbound container can be found at:
https://github.com/elico/unbound-container

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
I already run pihole in my router (veth1 interface) my ip 10.8.8.2.
So i have to remove container before install yours?

Re: Unbound container setup

Posted: Tue Jan 10, 2023 4:33 am
by elico
No,
Just adjust the ip addresses to your containers network subnet.


Just a recursive caching DNS server?

A simple unbound container can be found at:
https://github.com/elico/unbound-container

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
I already run pihole in my router (veth1 interface) my ip 10.8.8.2.
So i have to remove container before install yours?