I tried to setup an simple VXLAN-Environment between two Mikrotik Devices (mAP2) which transparently transfer the two Vlan IDs 20(untagged) and 30(tagged) to ether2 on each device.
I installed the RouterOS 7.8 on both devices and the two devices are connect for test directly via ether1 and IPv4.
I can ping directly between connection 10.0.0.1 and 10.0.0.2.
But I can't ping vxlan interfaces on the other mAP device.
I've tried the same configuration between an RB4011 and CCR1036 device, where this configuration works, but sporadicaly the CCR make an reboot.
Are any hardware requirements for use vxlan with bridge?
I've searched in the forum for this probem, and found like this. Maybe any parallels?
viewtopic.php?p=991350&hilit=vxlan#p991350
R1 Setup:
Code: Select all
/interface bridge
add name=brVX vlan-filtering=yes protocol-mode=none
/interface vlan
add name=vx20 interface=brVX vlan-id=20
add name=vx30 interface=brVX vlan-id=30
/ip address
add address=10.0.0.1/24 interface=ether1
add address=10.0.20.1/24 interface=vx20
add address=10.0.30.1/24 interface=vx30
/interface vxlan
add mtu=1400 name=vxlanTest group=224.10.2.1 interface=ether1 vni=10
/interface bridge port
add bridge=brVX interface=ether2 pvid=20
add bridge=brVX interface=vxlanTest
/interface bridge vlan
add bridge=brVX vlan-ids=20 tagged=brVX,vxlanTest untagged=ether2
add bridge=brVX vlan-ids=30 tagged=brVX,vxlanTest,ether2
R2 Setup:
Code: Select all
/interface bridge
add name=brVX vlan-filtering=yes protocol-mode=none
/interface vlan
add name=vx20 interface=brVX vlan-id=20
add name=vx30 interface=brVX vlan-id=30
/ip address
add address=10.0.0.2/24 interface=ether1
add address=10.0.20.2/24 interface=vx20
add address=10.0.30.2/24 interface=vx30
/interface vxlan
add mtu=1400 name=vxlanTest group=224.10.2.1 interface=ether1 vni=10
/interface bridge port
add bridge=brVX interface=ether2 pvid=20
add bridge=brVX interface=vxlanTest
/interface bridge vlan
add bridge=brVX vlan-ids=20 tagged=brVX,vxlanTest untagged=ether2
add bridge=brVX vlan-ids=30 tagged=brVX,vxlanTest,ether2