Hopefully someone can shed some light on this issue. I have a small setup consisting of a HEXs (RB760iGS), CSS106 (RB260GSP) and a cAP ac (RBcAPGi-5acD2ND).
There is a trunk uplink carrying four VLANs from the HEXs > CSS106. This is implemented using bridge VLAN filtering and specific VLAN interfaces and works perfectly. On the CSS I am able to lock down the port to only accept tagged traffic with;
VLAN Tab
Ingress
VLAN Mode: Strict
VLAN Receive: Only tagged
Default VLAN ID: 1
Force VLAN ID: no
Egress
VLAN Header: Leave as is
VLANs Tab
'Add if missing' on all ports for the all VLANs
Now for the cAP ac I set up VLANs on a bridge with VLAN filtering just the same. One VLAN interface in each VLAN and with the DHCP client running on each. See below config;
Code: Select all
/interface bridge
add frame-types=admit-only-vlan-tagged ingress-filtering=no name=bridge1 \
vlan-filtering=yes
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan12 vlan-id=12
add interface=bridge1 name=vlan13 vlan-id=13
add interface=bridge1 name=vlan14 vlan-id=14
/interface bridge port
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=ether1
/interface bridge vlan
add bridge=bridge1 tagged=bridge1,ether1 vlan-ids=10
add bridge=bridge1 tagged=bridge1,ether1 vlan-ids=12
add bridge=bridge1 tagged=bridge1,ether1 vlan-ids=13
add bridge=bridge1 tagged=bridge1,ether1 vlan-ids=14
/ip dhcp-client
add interface=vlan10
add interface=vlan12
add interface=vlan13
add interface=vlan14
But in this case if I set the trunk port from the CSS106 accordingly as above I can now longer reach the device. It seems frames are being dropped. But if I set VLAN Receive Mode to 'any' it works fine. I know frames are landing on the correct VLANs as the DHCP IPs are allocated correctly on the VLANs.
I understand the cAP ac has a switch chip and it can be configured under /interface/ethernet/switch/ to gain hardware support, but I find the software bridge more logical and simpler to manage/configure. Plus, requirements in this case dictate hardware support isn't going to add much.
I've seen advice here as;
Basic rule of thumb Trunk----> enabled/any/1/leave as is (for port membership leave as is for all applicable ports on incoming trunk and all applicable tagged ports)
Basic rule of thumb Access--->strict/only untagged/pvid#/always strip (for port membership, not a member except for applicable port(s))
And also the manual says;
VLAN Receive: Defines the type of allowed packets on ingress port: any / only tagged / only untagged (only supported on RB260GS)
But can anyone explain why it works in the first case? I can't understand it.
NOTE: I know there are no wireless interfaces and such. This is quick test setup to isolate this issue. I will be using CAPsMAN to manage/provision the AP.
Thanks,
t04s