"interface list 2 -> interface list 1 -> interface" works, but
"interface list 3 -> interface list 2 -> interface list 1 -> interface" doesnt.
This configuration:
Code: Select all
/interface list add name=il-test1
/interface list member add list=il-test1 interface=ether2
/interface list add name=il-test2 include=il-test1
/interface list add name=il-test3 include=il-test2
/ip firewall filter add action=log chain=input in-interface-list=il-test1 log=yes log-prefix=test1 protocol=icmp
/ip firewall filter add action=log chain=input in-interface-list=il-test2 log=yes log-prefix=test2 protocol=icmp
/ip firewall filter add action=log chain=input in-interface-list=il-test3 log=yes log-prefix=test3 protocol=icmp
Code: Select all
09:43:16 firewall,info test1 input: in:ether2 out:(unknown 0), connection-state:new src-mac xx:xx:xx:xx:xx:xx, proto ICMP (type 8, code 0), 192.168.88.2->192.168.88.1, len 60
09:43:16 firewall,info test2 input: in:ether2 out:(unknown 0), connection-state:new src-mac xx:xx:xx:xx:xx:xx, proto ICMP (type 8, code 0), 192.168.88.2->192.168.88.1, len 60
Nested includes in interface lists are not mentioned in the docs, so IDK if it's a bug or feature.
ROS 7.7 and 7.10.