Thank you for replying and the time to take a look at this.
- First the 2 routers with v6 with neighbors adjacencies / default route (ether1 connecting both):
### R1-v6.48.6 ###
/routing ospf interface
add interface=Loopback network-type=point-to-point
add authentication=md5 authentication-key=***** interface=ether5 network-type=point-to-point
add authentication=md5 authentication-key=***** interface=ether1 network-type=point-to-point
/routing ospf network
add area=10 network=10.1.200.200/30
add area=10 network=10.1.1.68/30
add area=10 network=10.1.1.112/30 (ether1)
add area=10 network=10.1.100.70/32
1 instance=default router-id=10.1.100.71 address=10.1.1.114 interface=ether1 priority=1 dr-address=0.0.0.0 backup-dr-address=0.0.0.0 state="Full"
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 0.0.0.0/0 10.1.1.69 110
1 ADo 10.0.0.32/30 10.1.1.69 110
2 ADo 10.0.1.0/30 10.1.1.69 110
3 ADo 10.0.1.4/30 10.1.1.69 110
4 ADo 10.0.1.8/30 10.1.1.69 110
5 ADo 10.0.1.12/30 10.1.1.69 110
…
### R2-v6.48.6 ###
/routing ospf interface
add interface=Loopback network-type=point-to-point
add authentication=md5 authentication-key=***** interface=ether1 network-type=point-to-point
add interface=BRIDGE network-type=point-to-point passive=yes
add authentication=md5 authentication-key=***** cost=20 interface=ether5 network-type=point-to-point (to v7 router)
/routing ospf network
add area=10 network=10.1.1.112/30 (ether1)
add area=10 network=10.1.1.116/30 (to v7 router)
add area=10 network=10.1.200.204/30
add area=10 network=100.66.23.0/24
add area=10 network=10.1.200.208/30
add area=10 network=10.1.200.212/30
add area=10 network=10.1.100.71/32
1 instance=default router-id=10.1.100.70 address=10.1.1.113 interface=ether1 priority=1 dr-address=0.0.0.0 backup-dr-address=0.0.0.0 state="Full"
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 0.0.0.0/0 10.1.1.113 110
10.1.1.118
1 ADo 10.0.0.32/30 10.1.1.113 110
10.1.1.118
2 ADo 10.0.1.0/30 10.1.1.113 110
10.1.1.118
3 ADo 10.0.1.4/30 10.1.1.113 110
- and the v7 router:
### R3-v7.10.1 ###
/routing ospf interface-template
add area=10 cost=10 disabled=no interfaces=Loopback networks=10.1.100.80/32 priority=1 type=ptp
add area=10 auth=md5 auth-id=1 auth-key=**** cost=10 disabled=no interfaces=ether1 networks=10.1.1.136/30 priority=1 type=ptp
add area=10 cost=10 disabled=no interfaces=ether2 networks=10.1.200.220/30 priority=1 type=ptp
add area=10 cost=10 disabled=no interfaces=ether2 networks=100.66.24.0/24 priority=1 type=ptp
add area=10 cost=10 disabled=no interfaces=ether3 networks=100.66.25.0/24 passive priority=1 type=ptp
add area=10 auth=md5 auth-id=1 auth-key=**** cost=20 disabled=no interfaces=ether4 networks=10.1.1.116/30 priority=1 type=ptp (to v6 router, redundant route)
add area=10 auth=md5 auth-id=1 auth-key=**** cost=10 disabled=no interfaces=ether4 networks=10.1.200.216/30 priority=1 type=ptp
add area=10 auth=md5 auth-id=1 auth-key=**** cost=10 disabled=no interfaces=ether5 networks=10.1.1.120/30 priority=1 type=ptp
add area=10 cost=10 disabled=no interfaces=ether5 networks=10.1.200.224/30 priority=1 type=ptp
add area=10 auth=md5 auth-id=1 auth-key=**** cost=10 disabled=no interfaces=ether6 networks=10.1.1.176/30 priority=1 type=ptp (main gateway, also to a v6 router)
add area=10 cost=10 disabled=no interfaces=ether6 networks=10.1.201.40/30 priority=1 type=ptp
…
0 D instance=default area=10 address=10.1.1.138 router-id=10.1.100.81 state="Full" state-changes=5 ls-retransmits=1 adjacency=5d17h24m24s timeout=40s
1 D instance=default area=10 address=10.1.1.122 router-id=10.1.100.90 state="Full" state-changes=4 ls-retransmits=1 adjacency=5d17h24m29s timeout=34s
2 D instance=default area=10 address=10.1.1.117 router-id=10.1.100.71 state="Full" state-changes=9 ls-retransmits=1 adjacency=3d23h49m56s timeout=37s
3 D instance=default area=10 address=10.1.1.177 router-id=10.1.100.10 state="Full" state-changes=4 adjacency=1d5h51m13s timeout=37s
# DST-ADDRESS GATEWAY DISTANCE
0 s 0.0.0.0/0 10.1.1.117 10
1 As 0.0.0.0/0 10.1.1.177 1
DAo 10.1.1.4/30 10.1.1.177%ether6 110
DAo 10.1.1.8/30 10.1.1.177%ether6 110
also, do you have any route filters on incoming route to that v7?
On the v7 itself, no. Bellow a standard config for a v6 instance, hope that answers your question:
/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never !domain-id !domain-tag in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto metric-rip=20 metric-static=20 !mpls-te-area !mpls-te-router-id name=\
default out-filter=ospf-out redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no router-id=10.1.100.71 !routing-table !use-dn