I've done all the certificates and ppp user-password stuff, then created the ip pool for ovpn
Code: Select all
/ip pool
add name=ovpn-pool ranges=192.168.100.10-192.168.100.20
/ip firewall filter
add chain=forward src-address=192.168.100.0/24 action=accept comment="Allow OpenVPN clients"
add chain=input protocol=tcp dst-port=1194 action=accept comment="Allow OpenVPN"
add chain=input in-interface=all-ppp action=accept comment="Allow OVPN clients"
Now, if I am correct proxy-arp ( https://blog.nmoleosoftware.com/index.p ... outeros-7/ ) is not needed since the VPN pool is on a different network, not LAN: LAN is 192.168.1.X , I put such route in the ovpn client config file
route 192.168.1.0 255.255.255.0
(but I had already anyway proxy-arp in my local bridge from a previous L2TP setup)
Then, https://www.raffaelechiatto.com/configu ... n-interna/ says:
Code: Select all
/ip firewall nat
add chain=srcnat src-address=192.168.100.0/24 action=masquerade
EDIT: sorry, I edited my post twice since I discovered other errors when checking again my setup...