DNS forwarding
Posted: Fri Jul 28, 2023 10:25 pm
Hi,
I have a setup with forwarding DNS queries for specific domain to local DNS server:
when I query dns this way all works:
but when I do:
What is weird that it worked at some point and stopped, and there were no changes in rourer configuration.
Tested on RouterOS 7.10.1 without DoH
any ideas what might be wrong? I thought it may be related to connection tracking, but no changes after clearing contrack table
Ser@fin
I have a setup with forwarding DNS queries for specific domain to local DNS server:
Code: Select all
/ip dns static
add address=192.168.8.7 name=ns.xxx ttl=1h
add address=192.168.8.9 name=ns.xxx ttl=1h
add forward-to=ns.xxx match-subdomain=yes name=xxx.local ttl=1h type=FWD
Code: Select all
:put [:resolve yyy.xxx.local server=192.168.8.7]
192.168.8.3
Code: Select all
:put [:resolve yyy.xxx.local]
failure: dns name does not exist
Tested on RouterOS 7.10.1 without DoH
any ideas what might be wrong? I thought it may be related to connection tracking, but no changes after clearing contrack table
Ser@fin