I have vlan filtering setup and a dhcp server running on a bridge, a trunk from a service provider with S-TAG outer and C-TAG inner ids for the end user routers. I need to allocate IP addresses down the link to each router on the other end of the cvlans.
I setup vlan filtering on a bridge, added the vlan that's mapped to the S-TAG and adding vlans on the bridge I can see the end user routers C-TAG id and mac addresses in the hosts on the bridge.
The DHCP server attached to the bridge sees the DHCP discovery from the end user devices and offers an address, but it's not getting back down the cvlans to the end user routers.
Here's my current config;
Code: Select all
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface bonding
add mode=802.3ad name="SL LACP" slaves=sfpplus1
/interface vlan
add interface="SL LACP" name=slc-VIC vlan-id=161
/ip dhcp-server
add address-pool=slc-VIC disabled=no interface=bridge1 name=server1
/interface bridge port
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=slc-VIC
/interface bridge settings
set allow-fast-path=no use-ip-firewall=yes use-ip-firewall-for-vlan=yes
/interface bridge vlan
add bridge=bridge1 tagged=slc-VIC untagged=bridge1 vlan-ids=2,8
/ip address
add address=192.168.0.1/24 interface=bridge1 network=192.168.0.0
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.0.1
/ip pool
add name=slc-VIC ranges=192.168.0.10-192.168.0.20
It seems there's no tagging on the way back down the cvlans, I'm sure I'm missing something simple.