We have recently switched our wifi setup to all Mikrotik CAP AX.
We are using CAPsMANv2 but we are experiencing some strange behavior in the following situations:
1. FT and FT over DS disabled - Device will connect to wifi but not to the closes AP, thus low performance and it can be observed that the device is on 2.4 rather than 5 GHz even thought band steering is enabled. Roaming does work but very slow and unreliable.
2. FT and FT over DS enabled - Device will connect to wifi, closest AP, initial performance is ok but after a couple of minutes the device begins to jump around APs even if they have worse signal / performance. We have some edge cases where the roaming happens so often that the device resuses to connect to wifi and dropps out of the network.
I have tried different variations of config and the issues do not seem to be linked to one particular device vendor. We observed this issues both on Android, iOS and Windows.
Attached the CAPsMAN configuration. All devices AP and CAPsMAN are on FW 7.14.1.
Code: Select all
/interface wifi channel
add band=2ghz-ax disabled=no frequency=2412,2437,2462 name="2.4 GHz" width=20mhz
add band=5ghz-ax disabled=no name="5 GHz" skip-dfs-channels=10min-cac width=20/40/80mhz
/interface wifi datapath
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 24" vlan-id=24
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 26" vlan-id=26
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 40" vlan-id=40
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 50" vlan-id=50
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 60" vlan-id=60
add bridge=bridge-LAN client-isolation=yes disabled=no name="VLAN 168" vlan-id=168
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 500" vlan-id=500
/interface wifi security
add authentication-types=wpa2-psk disabled=no encryption="" name=WPA2-PSK
add authentication-types=wpa2-psk disabled=no encryption="" name="WPA2-PSK IoT"
add authentication-types=wpa3-psk disabled=no encryption="" name=WPA3-PSK
add authentication-types=wpa2-psk disabled=no name="WPA2-PSK Guest"
add authentication-types=wpa2-psk disabled=no encryption="" name="WPA2-PSK Ortoprofil"
/interface wifi configuration
add channel="2.4 GHz" country=Romania datapath="VLAN 24" disabled=no mode=ap name="VLAN 24 2.4" security=WPA2-PSK ssid="HCS WLAN"
add channel="5 GHz" country=Romania datapath="VLAN 24" disabled=no mode=ap name="VLAN 24 5" security=WPA2-PSK ssid="HCS WLAN"
add channel="2.4 GHz" country=Romania datapath="VLAN 26" disabled=no mode=ap name="VLAN 26 2.4" security=WPA2-PSK ssid="HCS Mobile"
add channel="5 GHz" country=Romania datapath="VLAN 26" disabled=no mode=ap name="VLAN 26 5" security=WPA2-PSK ssid="HCS Mobile"
add channel="2.4 GHz" country=Romania datapath="VLAN 26" disabled=no mode=ap name="VLAN 26 2.4 IoT" security="WPA2-PSK IoT" ssid="HCS IoT"
add channel="2.4 GHz" country=Romania datapath="VLAN 40" disabled=no mode=ap name="VLAN 40 2.4" security=WPA2-PSK ssid="HCS Printer"
add channel="2.4 GHz" country=Romania datapath="VLAN 50" disabled=no mode=ap name="VLAN 50 2.4" security=WPA2-PSK ssid="HCS CCTV"
add channel="2.4 GHz" country=Romania datapath="VLAN 60" disabled=no mode=ap name="VLAN 60 2.4" security=WPA2-PSK ssid="HCS VoIP"
add channel="2.4 GHz" country=Romania datapath="VLAN 168" disabled=no mode=ap name="VLAN 168 2.4" security="WPA2-PSK Guest" ssid="HCS Guest"
add channel="2.4 GHz" country=Romania datapath="VLAN 500" disabled=no mode=ap name="VLAN 500 2.4" security="WPA2-PSK Ortoprofil" ssid=Ortoprofil
add channel="5 GHz" country=Romania datapath="VLAN 40" disabled=no mode=ap name="VLAN 40 5" security=WPA2-PSK ssid="HCS Printer"
add channel="5 GHz" country=Romania datapath="VLAN 50" disabled=no mode=ap name="VLAN 50 5" security=WPA2-PSK ssid="HCS CCTV"
add channel="5 GHz" country=Romania datapath="VLAN 60" disabled=no mode=ap name="VLAN 60 5" security=WPA2-PSK ssid="HCS VoIP"
add channel="5 GHz" country=Romania datapath="VLAN 168" disabled=no mode=ap name="VLAN 168 5" security="WPA2-PSK Guest" ssid="HCS Guest"
add channel="5 GHz" country=Romania datapath="VLAN 500" disabled=no mode=ap name="VLAN 500 5" security="WPA2-PSK Ortoprofil" ssid=Ortoprofil
add channel="2.4 GHz" country=Romania datapath="VLAN 24" disabled=no mode=ap name="VLAN 24 2.4 Test" security=WPA2-PSK ssid="Test 2"
add channel="5 GHz" country=Romania datapath="VLAN 24" disabled=no mode=ap name="VLAN 24 5 Test" security=WPA2-PSK ssid="Test 5"
add channel="2.4 GHz" country=Romania datapath="VLAN 168" disabled=no mode=ap name="VLAN 168 2.4 Test" security="WPA2-PSK Guest" ssid="Guest 2"
add channel="5 GHz" country=Romania datapath="VLAN 168" disabled=no mode=ap name="VLAN 168 5 Test" security="WPA2-PSK Guest" ssid="Guest 5"
/interface wifi steering
add disabled=no name=HCS-WLAN-BS neighbor-group="dynamic-HCS WLAN-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-IoT-BS neighbor-group="dynamic-HCS IoT-9cdd3b02" rrm=yes wnm=yes
add disabled=no name=HCS-Mobile-BS neighbor-group="dynamic-HCS Mobile-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-Printer-BS neighbor-group="dynamic-HCS Printer-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-CCTV-BS neighbor-group="dynamic-HCS CCTV-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-Guest-BS neighbor-group="dynamic-HCS Guest-ba07952c" rrm=yes wnm=yes
/interface wifi capsman
set ca-certificate=WiFi-CAPsMAN-CA-C4AD3418D4F6 certificate=WiFi-CAPsMAN-C4AD3418D4F6 enabled=yes interfaces=bridge-LAN package-path="" require-peer-certificate=no \
upgrade-policy=none
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no master-configuration="VLAN 24 2.4" name-format=%I-2G slave-configurations=\
"VLAN 26 2.4,VLAN 26 2.4 IoT,VLAN 40 2.4,VLAN 50 2.4,VLAN 60 2.4,VLAN 168 2.4,VLAN 500 2.4,VLAN 24 2.4 Test" supported-bands=2ghz-ax
add action=create-dynamic-enabled disabled=no master-configuration="VLAN 24 5" name-format=%I-5G slave-configurations=\
"VLAN 26 5,VLAN 40 5,VLAN 50 5,VLAN 60 5,VLAN 168 5,VLAN 500 5,VLAN 24 5 Test" supported-bands=5ghz-ax