Greetings,
Looking to see a fully working config for a /29 network. Maybe even different examples if you have them. Rough network diagram attached.
I have a CCR2004, it came without a config. I want this monolithic ip per server setup to support FTP server. If I'm doing the simple setup as mentioned in the first paragraph, what do I do with the sfp+1 interface? If .178 is assigned to the bridge, can it also exist on the sfp+1 port?Assuming you have the default firewall/config, you need to add the new bridge interface to the "WAN" interface list (under Interfaces > Lists) to protect the router.
No. Leave the address as /29./ip address
add address=x.x.x.178/29 interface=bridge1 network=x.x.x.176
>>> do I add this??: add address=x.x.x.178 interface=sfp-sfpplus1 network=x.x.x.177
/ip route add gateway=x.x.x.177
If you want to make it a switch for the WAN, then yes:/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
>>> do I add this??: add bridge=bridge1 interface=sfp-sfpplus1
/interface bridge port add bridge=bridge1 interface=sfp-sfpplus1
/interface bridge
add name=bridge1
add name=bridge2
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.1.100-192.168.1.150
/ip dhcp-server
add address-pool=dhcp interface=bridge2 lease-time=1d name=dhcp1
/port
set 0 name=serial0
set 1 name=serial1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge2 interface=ether9
add bridge=bridge2 interface=ether10
add bridge=bridge2 interface=ether11
add bridge=bridge2 interface=ether12
add bridge=bridge2 interface=ether13
add bridge=bridge2 interface=ether14
add bridge=bridge2 interface=ether15
add bridge=bridge2 interface=ether16
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface list member
add interface=bridge1 list=WAN
add interface=bridge2 list=LAN
/ip address
add address=192.168.1.1/24 interface=bridge2 network=192.168.1.0
add address=x.x.x.178/29 interface=bridge1 network=x.x.x.176
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8,1.1.1.1 gateway=192.168.1.1 netmask=24
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=x.x.x.177 routing-table=main \
suppress-hw-offload=no
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related hw-offload=yes
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ipv6/settings/set disable-ipv6=yes