I have a RB750Gr3
port1 and 2 for ISP, port 4 for a guest network (only internet) and port 5 for local LAN
I've been working with a LOCAL lan brindge no issues until I decided to put an AP directly connected to port 4 and manage a guest network; I've followed the basics, created a new bridge including port 3 and 4 (in case I add another AP on port 3 on the future)
- gave the bridge an IP address: 10.1.1.254
- created a new DHCP server for the guest network 10.1.1.0/24, it has its own network and pool on the same range.
Code: Select all
[root@RouterOS] > /ip address export
# 2024-05-22 16:32:58 by RouterOS 7.14.3
# software id = G6P4-6R9U
#
# model = RB750Gr3
# serial number = XXXXXXXXXXX
/ip address
add address=192.168.1.201/24 comment=defconf interface=LOCAL_Oncos network=192.168.1.0
add address=10.1.1.254/24 comment=invitados interface=invitados_Oncos network=10.1.1.0
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=8.8.8.8 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=32
add disabled=no dst-address=8.8.8.8/32 gateway=172.16.1.1 routing-table=main scope=30 suppress-hw-offload=no target-scope=31
[root@RouterOS] > /interface/
6to4 dot1x gre l2tp-client lte ovpn-client pppoe-client sstp-client vpls wireguard disable find reset-counters
bonding eoip gre6 l2tp-ether macsec ovpn-server pppoe-server sstp-server vrrp wireless edit monitor-traffic set
bridge eoipv6 ipip l2tp-server macvlan ppp-client pptp-client veth vxlan blink enable print
detect-internet ethernet ipipv6 list mesh ppp-server pptp-server vlan wifi comment export reset
/interface bridge
add admin-mac=48:A9:8A:EB:60:96 auto-mac=no comment=defconf name=LOCAL_Oncos port-cost-mode=short
add name=invitados_Oncos
/interface ethernet
set [ find default-name=ether1 ] name=ether1_ISP1
set [ find default-name=ether2 ] name=ether2_ISP2
set [ find default-name=ether4 ] name=ether4_invitados
set [ find default-name=ether5 ] name=ether5_ONCOS
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=LOCAL_Oncos comment=defconf ingress-filtering=no interface=ether5_ONCOS internal-path-cost=10 path-cost=10
add bridge=invitados_Oncos interface=ether4_invitados
/interface list member
add comment=defconf interface=LOCAL_Oncos list=LAN
add comment=defconf interface=ether1_ISP1 list=WAN
add interface=ether2_ISP2 list=WAN
add interface=invitados_Oncos list=LAN
/interface ovpn-server server
set auth=sha1,md5
/ip dhcp-server
add address-pool=default-dhcp interface=LOCAL_Oncos lease-time=10m name=defconf
add address-pool=pool_invitados interface=invitados_Oncos lease-time=10m name=server_invitados
/ip dhcp-server lease
add address=192.168.1.190 mac-address=F4:B1:C2:6D:E0:40
add address=192.168.1.195 mac-address=00:19:BA:08:C1:66
add address=192.168.1.200 mac-address=00:17:61:10:7F:5A
add address=192.168.1.254 mac-address=00:5F:67:75:F7:69
add address=192.168.1.249 client-id=ff:70:5c:d1:7b:0:1:0:1:2d:32:dd:4:6:77:70:5c:d1:7b mac-address=06:77:70:5C:D1:7B server=defconf
add address=192.168.1.198 client-id=1:8e:b5:47:46:80:d6 mac-address=8E:B5:47:46:80:D6 server=defconf
add address=192.168.1.253 client-id=1:e:31:c4:c0:d8:3 comment="TRUENAS oserv1" mac-address=0E:31:C4:C0:D8:03 server=defconf
add address=192.168.1.250 comment=truenas_mirror mac-address=BC:24:11:02:11:95
/ip dhcp-server network
add address=10.1.1.0/24 comment=invitados dns-server=8.8.8.8 gateway=10.1.1.254 netmask=24
add address=192.168.1.0/24 comment=defconf dns-server=8.8.8.8 gateway=192.168.1.201 netmask=24
/ip firewall address-list
add address=192.168.1.111 list=dns_server
/ip firewall connection tracking
set udp-timeout=10s
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN log=yes log-prefix=noLAN_
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
add action=accept chain=forward disabled=yes
add action=accept chain=input disabled=yes
/ip firewall mangle
add action=mark-connection chain=prerouting comment="marks from ISP interface" connection-mark=no-mark connection-state=new disabled=yes in-interface=ether1_ISP1 new-connection-mark=ISP1_conn passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new disabled=yes in-interface=ether2_ISP2 new-connection-mark=ISP2_conn passthrough=yes
add action=mark-routing chain=output comment="marks toISP interface" connection-mark=ISP1_conn disabled=yes new-routing-mark=ISP1 passthrough=yes
add action=mark-routing chain=output connection-mark=ISP2_conn disabled=yes new-routing-mark=ISP2 passthrough=yes
add action=mark-connection chain=prerouting comment="marks from LAN interface" connection-mark=no-mark connection-state=new disabled=yes dst-address-type=!local in-interface=LOCAL_Oncos new-connection-mark=ISP1_conn passthrough=yes \
per-connection-classifier=src-address-and-port:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new disabled=yes dst-address-type=!local in-interface=LOCAL_Oncos new-connection-mark=ISP2_conn passthrough=yes per-connection-classifier=src-address-and-port:2/1
add action=mark-routing chain=prerouting comment="marks to LAN interface" connection-mark=ISP1_conn disabled=yes in-interface=LOCAL_Oncos new-routing-mark=ISP1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=ISP2_conn disabled=yes in-interface=LOCAL_Oncos new-routing-mark=ISP2 passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat dst-port=53 protocol=tcp src-address-list=!dns_server to-addresses=8.8.8.8
add action=dst-nat chain=dstnat dst-port=53 protocol=udp src-address-list=!dns_server to-addresses=8.8.8.8
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
Current state is clients receive an IP and correct DHCP settings, gateway, DNS, etc.
But they can only talk to each other, no link to the internet, not even ping to their own gateway 10.1.1.254