BGP is very long time send prefix out network after session established. About an hour to two.
How to fix it? Tested on 7.13.5 7.14.3 7.15.1
Code: Select all
/routing bgp template
set default address-families=ip as=my.ASN cisco-vpls-nlri-len-fmt=auto-bits disabled=no hold-time=3m nexthop-choice=default output.network=Own.Net.BGP router-id=my.ID routing-table=Users vrf=Users
/routing bgp connection
add address-families=ip as=my.ASN cisco-vpls-nlri-len-fmt=auto-bits connect=yes disabled=no hold-time=30s input.affinity=alone .filter=AS20485-bgp-in listen=yes local.address=my.ip.add .role=ebgp name=peer1 nexthop-choice=default output.affinity=alone .default-originate=never .filter-chain=AS20485-bgp-out .network=Own.Net.BGP remote.address=peer.ip.add/32 .as=20485 router-id=my.ID routing-table=Users templates=default vrf=Users
/routing filter rule
add chain=AS20485-bgp-in disabled=no rule="if (dst in 10.0.0.0/8) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 192.168.0.0/16) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 169.254.0.0/16) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 127.0.0.0/8) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 192.0.2.0/24) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 172.16.0.0/12) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 191.255.0.0/16) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 192.0.0.0/24) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 223.255.255.0/24) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 224.0.0.0/3) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in 100.64.0.0/10) {reject;}"
add chain=AS20485-bgp-in disabled=no rule="if (dst in my.prefix) {reject;}"
add chain=AS20485-bgp-in disabled=no rule=accept
add chain=AS20485-bgp-out disabled=no rule="if (dst == my.prefix) {accept;}"
add chain=AS20485-bgp-out disabled=no rule=reject
/ip firewall address-list
add address=my.prefix list=Own.Net.BGP