As a general statement, if you have an Internet facing port for very long you WILL be port scanned and have attempts on many of the common ports. You ISP will either laugh in your face, or at least laugh at you after ending the phone call if you ask them to fix that "problem". You need to stop those with your firewall rules - which it looks like you are doing.
As for your firewall rules question, rules are always processed in order. If an earlier rule is not doing anything, presumably it is not filtering what you think it should be. Beyond that, we would need to see your configuration to be able to answer. Post your configuration and ask your questions. To export and paste your configuration (and I'm assuming you are using WebFig or Winbox), open a terminal window, and type (without the quotes) "/export hide-sensitive file=any-filename-you-wish". Then open the files section and right click on the filename you created and select download in order to download the file to your computer. It will be a text file with whatever name you saved to with an extension of .rsc. Suggest you then open the .rsc file in your favorite text editor and redact any sensitive information. Then in your message here, click the code display icon in the toolbar above the text entry (the code display icon is the 7th one from the left and looks like a square with a blob in the middle). Then paste the text from the file in between the two code words in brackets.
I basically use the default config, just setup hairnat for game servers and some servers or services on raspberry pi:
# jul/10/2024 17:09:14 by RouterOS 6.49.15
#
# model = RB750Gr3
/interface bridge
add admin-mac=************ auto-mac=no comment=defconf name=bridge
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge lease-time=1d \
name=defconf
/queue type
add kind=sfq name=sfq-default sfq-perturb=10
/system logging action
set 1 disk-file-count=3 disk-file-name=disk1/log
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=none lldp-med-net-policy-vlan=1
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall address-list
add address=192.168.88.0/24 list=LAN-RANGE
/ip firewall filter
add action=drop chain=input dst-port=******,******,******,******,****** in-interface-list=!LAN \
log=yes log-prefix="blocked unauthorized" protocol=tcp
add action=drop chain=forward disabled=yes out-interface=ether1 src-address=\
192.168.88.195 src-address-list=""
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
dst-port=!****** in-interface-list=!LAN log=yes log-prefix="Not from LAN" \
protocol=tcp
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat dst-address=192.168.88.0/24 out-interface=\
bridge src-address=192.168.88.0/24
add action=dst-nat chain=dstnat comment="For any game server." dst-address=\
!192.168.88.0/24 dst-address-type=local dst-port=****** protocol=tcp \
to-addresses=192.168.88.2 to-ports=******
add action=dst-nat chain=dstnat dst-address=!192.168.88.0/24 \
dst-address-type=local dst-port=****** protocol=udp to-addresses=\
192.168.88.195 to-ports=******
add action=dst-nat chain=dstnat comment=OwnCloud dst-address=!192.168.88.0/24 \
dst-address-type=local dst-port=****** protocol=udp to-addresses=\
192.168.88.65 to-ports=****
add action=dst-nat chain=dstnat dst-address=!192.168.88.0/24 \
dst-address-type=local dst-port=****** protocol=tcp to-addresses=\
192.168.88.65 to-ports=******
add action=dst-nat chain=dstnat comment="Plex Media Server" dst-address=\
!192.168.88.0/24 dst-address-type=local dst-port=****** protocol=tcp \
to-addresses=192.168.88.65 to-ports=******
add action=dst-nat chain=dstnat comment=Grafana dst-address=!192.168.88.0/24 \
dst-address-type=local dst-port=****** protocol=tcp to-addresses=\
192.168.88.65 to-ports=******
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh address=192.168.88.0/24 port=******
set api disabled=yes
set winbox address=192.168.88.0/24
set api-ssl disabled=yes
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=ether1 type=external
/system logging
set 0 action=disk
set 1 action=disk
set 2 action=disk
set 3 action=disk
add action=disk topics=firewall
add action=disk topics=system
/system scheduler
add interval=1w name="Run backup" on-event=Backup policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=jul/10/2024 start-time=00:00:00
/system script
add dont-require-permissions=no name=Backup owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/system backup save name=\"/disk1/backup\""
/tool bandwidth-server
set enabled=no
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool mac-server ping
set enabled=no