So I bought a quite high enough number (about 50) CAP-AX APs and to be honest I need/want to know if I am stupid / did something wrong or the APs are not quit up to the task. So unfortunately I do not have plans of the building but is a 3 story building, interior walls are mostly brick. We have about 2-3 APs per floor positioned as best as possible as to not physically overlap. Signal is overall great, performance is great, stability... almost non existent. If we run each AP individually (meaning having a SSID per AP) than everything is great, everything under one/multiple identical SSIDs and hell breaks loose, roaming when there is no need to, device dropping connection and then reconnecting back, roaming not working when it should etc.
This is the config I am currently having:
Code: Select all
/interface wifi channel
add band=2ghz-ax disabled=no frequency=2412,2437,2462 name="2.4 GHz" width=20mhz
add band=5ghz-ax disabled=no name="5 GHz" skip-dfs-channels=all width=20/40mhz
/interface wifi datapath
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 24" vlan-id=24
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 26" vlan-id=26
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 40" vlan-id=40
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 50" vlan-id=50
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 60" vlan-id=60
add bridge=bridge-LAN client-isolation=yes disabled=no name="VLAN 168" vlan-id=168
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN 500" vlan-id=500
add bridge=bridge-LAN client-isolation=no disabled=no name="VLAN Trunk"
add bridge=bridge-LAN disabled=no name=1 vlan-id=1
/interface wifi security
add authentication-types=wpa2-psk,wpa3-psk disabled=no encryption="" ft=yes name=WPA2-PSK
add authentication-types=wpa2-psk disabled=no encryption="" name="WPA2-PSK IoT"
add authentication-types=wpa3-psk disabled=no encryption="" name=WPA3-PSK
add authentication-types=wpa2-psk disabled=no name="WPA2-PSK Guest"
add authentication-types=wpa2-psk disabled=no encryption="" name="WPA2-PSK Ortoprofil"
add authentication-types=wpa2-eap disabled=no eap-certificate-mode=verify-certificate-with-crl encryption="" ft=yes ft-over-ds=yes name=WPA2-EAP
/interface wifi configuration
add channel="2.4 GHz" country=Romania datapath="VLAN 24" disabled=no mode=ap name="VLAN 24 2.4" security=WPA2-PSK ssid="HCS WLAN"
add channel="5 GHz" channel.skip-dfs-channels=all country=Romania datapath="VLAN 24" disabled=no mode=ap name="VLAN 24 5" security=WPA2-PSK ssid="HCS WLAN"
add channel="2.4 GHz" country=Romania datapath="VLAN 26" disabled=no mode=ap name="VLAN 26 2.4" security=WPA2-PSK ssid="HCS Mobile"
add channel="5 GHz" country=Romania datapath="VLAN 26" disabled=no mode=ap name="VLAN 26 5" security=WPA2-PSK ssid="HCS Mobile"
add channel="2.4 GHz" country=Romania datapath="VLAN 26" disabled=no mode=ap name="VLAN 26 2.4 IoT" security="WPA2-PSK IoT" ssid="HCS IoT"
add channel="2.4 GHz" country=Romania datapath="VLAN 40" disabled=no mode=ap name="VLAN 40 2.4" security=WPA2-PSK ssid="HCS Printer"
add channel="2.4 GHz" country=Romania datapath="VLAN 50" disabled=no mode=ap name="VLAN 50 2.4" security=WPA2-PSK ssid="HCS CCTV"
add channel="2.4 GHz" country=Romania datapath="VLAN 60" disabled=no mode=ap name="VLAN 60 2.4" security=WPA2-PSK ssid="HCS VoIP"
add channel="2.4 GHz" country=Romania datapath="VLAN 168" disabled=no mode=ap name="VLAN 168 2.4" security="WPA2-PSK Guest" ssid="HCS Guest"
add channel="2.4 GHz" country=Romania datapath="VLAN 500" disabled=no mode=ap name="VLAN 500 2.4" security="WPA2-PSK Ortoprofil" ssid=Ortoprofil
add channel="5 GHz" country=Romania datapath="VLAN 40" disabled=no mode=ap name="VLAN 40 5" security=WPA2-PSK ssid="HCS Printer"
add channel="5 GHz" country=Romania datapath="VLAN 50" disabled=no mode=ap name="VLAN 50 5" security=WPA2-PSK ssid="HCS CCTV"
add channel="5 GHz" country=Romania datapath="VLAN 60" disabled=no mode=ap name="VLAN 60 5" security=WPA2-PSK ssid="HCS VoIP"
add channel="5 GHz" country=Romania datapath="VLAN 168" disabled=no mode=ap name="VLAN 168 5" security="WPA2-PSK Guest" ssid="HCS Guest"
add channel="5 GHz" country=Romania datapath="VLAN 500" disabled=no mode=ap name="VLAN 500 5" security="WPA2-PSK Ortoprofil" ssid=Ortoprofil
/interface wifi steering
add disabled=no name=HCS-WLAN-BS neighbor-group="dynamic-HCS WLAN-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-IoT-BS neighbor-group="dynamic-HCS IoT-9cdd3b02" rrm=yes wnm=yes
add disabled=no name=HCS-Mobile-BS neighbor-group="dynamic-HCS Mobile-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-Printer-BS neighbor-group="dynamic-HCS Printer-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-CCTV-BS neighbor-group="dynamic-HCS CCTV-cfc186f4" rrm=yes wnm=yes
add disabled=no name=HCS-Guest-BS neighbor-group="dynamic-HCS Guest-ba07952c" rrm=yes wnm=yes
/interface wifi access-list
add action=accept allow-signal-out-of-range=2s disabled=no interface=any signal-range=-70..-10
add action=reject disabled=no interface=any signal-range=-120..-76
/interface wifi capsman
set ca-certificate=WiFi-CAPsMAN-CA-C4AD3418D4F6 certificate=WiFi-CAPsMAN-C4AD3418D4F6 enabled=yes interfaces=bridge-LAN package-path="" require-peer-certificate=no \
upgrade-policy=none
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no master-configuration="VLAN 24 2.4" name-format=%I-2G slave-configurations=\
"VLAN 26 2.4,VLAN 26 2.4 IoT,VLAN 40 2.4,VLAN 50 2.4,VLAN 60 2.4,VLAN 168 2.4,VLAN 500 2.4" supported-bands=2ghz-ax
add action=create-dynamic-enabled disabled=no master-configuration="VLAN 24 5" name-format=%I-5G slave-configurations=\
"VLAN 26 5,VLAN 40 5,VLAN 50 5,VLAN 60 5,VLAN 168 5,VLAN 500 5" supported-bands=5ghz-ax
Roaming enabled on all of them except for the IoT.
I have tried various things such as implementing the access-list, reducing the power of the APs, enable/disable ft and ft-over-ds, but nothing seams to solve the issue.
So back to the initial question, am I stupid / did I do something wrong or the APs are not quit up to the task ?