I’ve configured WireGuard on my MikroTik router (version 7.16), and it’s working correctly for one peer (Hamed-PC). This peer is able to connect, access the internet, and use the tunnel without any issues. However, for a second peer (Omid), the handshake is successfully established, but no traffic passes through the tunnel.
Here’s my configuration:
Interface Configuration:
Code: Select all
/interface wireguard
add listen-port=40443 mtu=1420 name=WG private-key="QFBD8AfDtRK0UKxBcYw9lBYvDvlgGO29hnBNXC44jXM="
Code: Select all
/interface wireguard peers
add allowed-address=0.0.0.0/0 client-address=192.168.10.100/32 client-dns=8.8.8.8,4.2.2.4 client-endpoint=31.41.35.121 endpoint-address=31.41.35.121 endpoint-port=40443 interface=WG name=Hamed-PC private-key="SFbnsf4LR3yiLsMZNLNyo1BdLq6OaQpakLh6pAsWpWw=" public-key="4WQ8hizcFvtwYat2m48DAk1hfCXYztR+42D8p7xK7S4="
add allowed-address=0.0.0.0/0 client-address=192.168.10.101/32 client-dns=8.8.8.8,4.2.2.4 client-endpoint=31.41.35.121 endpoint-address=31.41.35.121 endpoint-port=40443 interface=WG name=Omid private-key="uOzYZiTG0lU3nHZ9TrSrQbmNRLuQMkUsT4psZkwDl2s=" public-key="p7AwXg1+Yv5yXxVYPmeQ1ee6982z4QW7uBkNX2cg3Gs="
- The WireGuard interface on the router has an IP address of 192.168.10.1/24.
NAT is configured and works perfectly for the first peer (Hamed-PC).
Firewall rules are set to allow WireGuard traffic on port 40443.
The handshake for both peers is established, but Omid cannot pass traffic.
- Verified NAT configuration and confirmed it works for the first peer (Hamed-PC).
Verified DNS and routing settings on the Omid client.
Checked WireGuard logs for both the router and the Omid client.
Pinged the Omid IP address (192.168.10.101) from the router but received no response.
What could cause one peer to work perfectly while another peer fails to pass traffic despite successful handshake? Any insights or suggestions for additional troubleshooting steps would be greatly appreciated.
Thank you in advance!