Working on a project where I needed to arrange for Winbox (computer) and MT app (iPhone) access to a dumb wireless pass-through bridge (a wireless station, but I mean it doesn't route) that couldn't be reached by other means. I need to do it from time to time to add/remove entries in the wireless connect-list and security-profiles tables. Thought I might add a virtual AP to the radio through which I could use Winbox on it to do this. My early attempts failed, with "failed to establish secure connection" from the iPhone MT app.
So I broke the problem down to basics: Winbox over Ethernet can access a MikroTik that has no configuration at all... but how minimal a configuration can you add to a wireless MikroTik in order to have wireless Winbox access?
I grabbed a lab router and came up with the configuration below, and then I made a discovery: it works absolutely fine for Winbox running on a computer, but the MT iPhone app hangs for a while and then just gives up with no message. So apparently the app has additional requirements that real Winbox does not. Does anybody know what I would have to add to this configuration to make the iPhone app happy enough to log in properly?
Code: Select all
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=MaintOwn supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-g/n country=no_country_set disabled=no mode=ap-bridge \
radio-name="Liberty Maint" security-profile=MaintOwn ssid="Liberty Maint" wps-mode=disabled
/ip pool
add name=MaintPool ranges=192.168.100.2/31
/ip dhcp-server
add address-pool=MaintPool interface=wlan1 name=MaintDHCP
/ip address
add address=192.168.100.1/24 interface=wlan1 network=192.168.100.0
/system note
set show-at-login=no