Ok, for starters you would have to download ISRG ROOT X1 and R10 and R11 as .pem, add them to the router's files ajd import them
/certificate
import isrgrootx1.pem
import r10.pem
import r11.pem
After that, you would create an IPsec profile and proposal:
/ip ipsec profile
add name=TheSafety_VPN
/ip ipsec proposal
add name=TheSafety_VPN pfs-group=none
Next, you would configure a policy group and a policy template for the traffic to be sent over the tunnel:
/ip ipsec policy group
add name=TheSafety_VPN
/ip ipsec policy
add dst-address=0.0.0.0/0 group=TheSafety_VPN proposal=TheSafety_VPN src-address=0.0.0.0/0 template=yes
Following, you add a mode configuration which would be later set to forward the desired traffic through the VPN:
/ip ipsec mode-config
add name=TheSafety_VPN responder=no
Further, you would add a peer and an identity - the most important parts; because in peer you add the address/DNS of the server you connect to and in identity the username and password:
/ip ipsec peer
add address=lou.msfcsi.com exchange-mode=ike2 name=TheSafety_VPN profile=TheSafety_VPN
/ip ipsec identity
add auth-method=eap certificate="" eap-methods=eap-mschapv2 generate-policy=port-strict mode-config=TheSafety_VPN peer=TheSafety_VPN policy-template-group=TheSafety_VPN username=myvpn password=myvpn
Lastly, after all this is done, you would need to consider traffic from which subnets should be sent over the tunnel by adding them in a firewall address list and adding the list itself in the mode-config settings:
/ip firewall address-list
add address=a.b.c.0/24 list=thr_VPN
/ip ipsec mode-config
set [ find name=TheSafety_VPN ] src-address-list=thr_VPN
FYI, the structure of my answer is based on the following article from the MikroTik Docs where there are more detailed explanations but for another VPN vendor:
https://help.mikrotik.com/docs/spaces/R ... d+RouterOS